summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2009-12-23 23:48:41 +0000
committerMike Auty <ikelos@gentoo.org>2009-12-23 23:48:41 +0000
commit0d1d7ec745843010b1ba7ae47b5b0579647bce4f (patch)
treed4cd8bc65d1ee9c9870ab294ece141a972125e0d /x11-drivers
parentUpdate EAPI checks. Add support for -2, -3, --only-ABI and --final-ABI option... (diff)
downloadgentoo-2-0d1d7ec745843010b1ba7ae47b5b0579647bce4f.tar.gz
gentoo-2-0d1d7ec745843010b1ba7ae47b5b0579647bce4f.tar.bz2
gentoo-2-0d1d7ec745843010b1ba7ae47b5b0579647bce4f.zip
Version bump to 0.10.3, now includes a (testing) version of xsetwacom.
(Portage version: 2.2_rc60/cvs/Linux i686)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-wacom/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.3.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-wacom/ChangeLog b/x11-drivers/xf86-input-wacom/ChangeLog
index 512b85ce390f..11564e769932 100644
--- a/x11-drivers/xf86-input-wacom/ChangeLog
+++ b/x11-drivers/xf86-input-wacom/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-wacom
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.7 2009/12/10 08:51:36 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.8 2009/12/23 23:48:41 ikelos Exp $
+
+*xf86-input-wacom-0.10.3 (23 Dec 2009)
+
+ 23 Dec 2009; Mike Auty <ikelos@gentoo.org>
+ +xf86-input-wacom-0.10.3.ebuild:
+ Version bump to 0.10.3, now includes a (testing) version of xsetwacom.
10 Dec 2009; Zac Medico <zmedico@gentoo.org>
xf86-input-wacom-0.10.0.ebuild, xf86-input-wacom-0.10.1.ebuild,
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.3.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.3.ebuild
new file mode 100644
index 000000000000..3fdfdbe342da
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.3.ebuild,v 1.1 2009/12/23 23:48:41 ikelos Exp $
+
+EAPI="2"
+
+inherit linux-info x-modular
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://anongit.freedesktop.org/~whot/xf86-input-wacom"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://people.freedesktop.org/~whot/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="hal debug"
+
+COMMON_DEPEND=">=x11-base/xorg-server-1.6
+ hal? ( sys-apps/hal )"
+RDEPEND="${COMMON_DEPEND}
+ !x11-drivers/linuxwacom"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ CONFIGURE_OPTIONS="$(use_enable debug)"
+}
+
+src_install() {
+ x-modular_src_install
+
+ if use hal; then
+ insinto /usr/share/hal/fdi/policy/10osvendor
+ newins "${S}"/fdi/wacom.fdi 11-x11-wacom.fdi
+ fi
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ if ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}