summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2009-11-20 13:03:52 +0000
committerMike Auty <ikelos@gentoo.org>2009-11-20 13:03:52 +0000
commitd61352c37c3eb768ecaaa2a8813e9f299cf8ef4a (patch)
tree9a575315349d53215648cb5400adc1f756304c30 /x11-drivers
parentAdd in optional dependency on tcpreplay to scapy-2.0.1 (bug 293821). (diff)
downloadgentoo-2-d61352c37c3eb768ecaaa2a8813e9f299cf8ef4a.tar.gz
gentoo-2-d61352c37c3eb768ecaaa2a8813e9f299cf8ef4a.tar.bz2
gentoo-2-d61352c37c3eb768ecaaa2a8813e9f299cf8ef4a.zip
Version bump, ebuild based on one courtesy of Matthew Turnbull (see bug 293797).
(Portage version: 2.2_rc50/cvs/Linux i686)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-wacom/ChangeLog9
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.1.ebuild53
2 files changed, 61 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-wacom/ChangeLog b/x11-drivers/xf86-input-wacom/ChangeLog
index a08c3a637910..8fab1b58d081 100644
--- a/x11-drivers/xf86-input-wacom/ChangeLog
+++ b/x11-drivers/xf86-input-wacom/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/xf86-input-wacom
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.3 2009/11/05 22:54:58 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.4 2009/11/20 13:03:52 ikelos Exp $
+
+*xf86-input-wacom-0.10.1 (20 Nov 2009)
+
+ 20 Nov 2009; Mike Auty <ikelos@gentoo.org>
+ +xf86-input-wacom-0.10.1.ebuild:
+ Version bump, ebuild based on one courtesy of Matthew Turnbull (see bug
+ 293797).
05 Nov 2009; Rémi Cardona <remi@gentoo.org>
xf86-input-wacom-0.10.0.ebuild:
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.1.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.1.ebuild
new file mode 100644
index 000000000000..80a66d0e090d
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.1.ebuild,v 1.1 2009/11/20 13:03:52 ikelos Exp $
+
+EAPI="2"
+
+inherit linux-info x-modular
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://anongit.freedesktop.org/~whot/xf86-input-wacom"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://people.freedesktop.org/~whot/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="hal debug"
+
+RDEPEND=">=x11-base/xorg-server-1.6
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ CONFIGURE_OPTIONS="$(use_enable debug)"
+}
+
+src_install() {
+ x-modular_src_install
+
+ if use hal; then
+ insinto /usr/share/hal/fdi/policy/10osvendor
+ newins "${S}"/fdi/wacom.fdi 11-x11-wacom.fdi
+ fi
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ if ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}