summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-07-05 08:37:00 +0000
committerBen de Groot <yngwin@gentoo.org>2009-07-05 08:37:00 +0000
commit6a1411ce1df3131521993e1a9c59dea659160378 (patch)
treea9d3f55b974922b9d3f3643274b0f5e1264d8918 /x11-libs/fltk
parentInitial import. (diff)
downloadgentoo-2-6a1411ce1df3131521993e1a9c59dea659160378.tar.gz
gentoo-2-6a1411ce1df3131521993e1a9c59dea659160378.tar.bz2
gentoo-2-6a1411ce1df3131521993e1a9c59dea659160378.zip
Add patches to make 1.1.9 build with glibc-2.10/gcc-4.4. Fixes bug 270487.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/fltk')
-rw-r--r--x11-libs/fltk/ChangeLog7
-rw-r--r--x11-libs/fltk/files/fltk-1.1.9-consts.patch20
-rw-r--r--x11-libs/fltk/files/fltk-1.1.9-glibc2.10-scandir.patch12
-rw-r--r--x11-libs/fltk/fltk-1.1.9.ebuild5
4 files changed, 42 insertions, 2 deletions
diff --git a/x11-libs/fltk/ChangeLog b/x11-libs/fltk/ChangeLog
index 9a8abab3a747..999e2ef90b04 100644
--- a/x11-libs/fltk/ChangeLog
+++ b/x11-libs/fltk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/fltk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.115 2009/07/04 18:38:30 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.116 2009/07/05 08:37:00 yngwin Exp $
+
+ 05 Jul 2009; Ben de Groot <yngwin@gentoo.org> fltk-1.1.9.ebuild,
+ +files/fltk-1.1.9-consts.patch, +files/fltk-1.1.9-glibc2.10-scandir.patch:
+ Add patches to make 1.1.9 build with glibc-2.10/gcc-4.4. Fixes bug 270487.
+ Patches originate from Fedora CVS.
04 Jul 2009; Ben de Groot <yngwin@gentoo.org>
+files/fltk2-glibc2.10-scandir.patch, fltk-2.0_pre6786.ebuild:
diff --git a/x11-libs/fltk/files/fltk-1.1.9-consts.patch b/x11-libs/fltk/files/fltk-1.1.9-consts.patch
new file mode 100644
index 000000000000..1ca0d84c9fc4
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.1.9-consts.patch
@@ -0,0 +1,20 @@
+diff -ru fltk-1.1.9.orig/src/fl_set_fonts_xft.cxx fltk-1.1.9/src/fl_set_fonts_xft.cxx
+--- fltk-1.1.9.orig/src/fl_set_fonts_xft.cxx 2009-03-04 10:58:49.000000000 +0000
++++ fltk-1.1.9/src/fl_set_fonts_xft.cxx 2009-03-04 11:01:25.000000000 +0000
+@@ -253,13 +253,13 @@
+ // So the bit we want is up to the first comma - BUT some strings have
+ // more than one name, separated by, guess what?, a comma...
+ stop = start = first = 0;
+- stop = strchr((const char *)font, ',');
+- start = strchr((const char *)font, ':');
++ stop = strchr((char *)font, ',');
++ start = strchr((char *)font, ':');
+ if ((stop) && (start) && (stop < start))
+ {
+ first = stop + 1; // discard first version of name
+ // find first comma *after* the end of the name
+- stop = strchr((const char *)start, ',');
++ stop = strchr((char *)start, ',');
+ }
+ else
+ {
diff --git a/x11-libs/fltk/files/fltk-1.1.9-glibc2.10-scandir.patch b/x11-libs/fltk/files/fltk-1.1.9-glibc2.10-scandir.patch
new file mode 100644
index 000000000000..0051306ebc2a
--- /dev/null
+++ b/x11-libs/fltk/files/fltk-1.1.9-glibc2.10-scandir.patch
@@ -0,0 +1,12 @@
+diff -up fltk-1.1.9/src/filename_list.cxx.gcc44 fltk-1.1.9/src/filename_list.cxx
+--- fltk-1.1.9/src/filename_list.cxx.gcc44 2006-06-09 11:16:34.000000000 -0500
++++ fltk-1.1.9/src/filename_list.cxx 2009-05-13 09:46:42.372917879 -0500
+@@ -67,7 +67,7 @@ int fl_filename_list(const char *d, dire
+ // The vast majority of UNIX systems want the sort function to have this
+ // prototype, most likely so that it can be passed to qsort without any
+ // changes:
+- int n = scandir(d, list, 0, (int(*)(const void*,const void*))sort);
++ int n = scandir(d, list, 0, (int(*)(const dirent **,const dirent **))sort);
+ #else
+ // This version is when we define our own scandir (WIN32 and perhaps
+ // some Unix systems) and apparently on IRIX:
diff --git a/x11-libs/fltk/fltk-1.1.9.ebuild b/x11-libs/fltk/fltk-1.1.9.ebuild
index 78450aa3248e..b062d68f08b1 100644
--- a/x11-libs/fltk/fltk-1.1.9.ebuild
+++ b/x11-libs/fltk/fltk-1.1.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.1.9.ebuild,v 1.5 2009/05/05 08:25:17 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.1.9.ebuild,v 1.6 2009/07/05 08:37:00 yngwin Exp $
EAPI=2
inherit eutils autotools versionator fdo-mime
@@ -42,6 +42,9 @@ src_prepare() {
# prevent to run twice configure (needs eautoconf), to compile tests,
# remove forced -Os compile
epatch "${FILESDIR}"/${P}-conf-tests.patch
+ # fix stricter c++ handling in glibc-2.10/gcc-4.4 (bug 270487)
+ epatch "${FILESDIR}"/${P}-glibc2.10-scandir.patch
+ epatch "${FILESDIR}"/${P}-consts.patch
# remove forced flags from fltk-config
sed -i \
-e '/C\(XX\)\?FLAGS=/s:@C\(XX\)\?FLAGS@::' \