summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2014-11-11 21:07:26 +0000
committerMatti Bickel <mabi@gentoo.org>2014-11-11 21:07:26 +0000
commitfb6ce5ac68f3ebd18930ee3d6b7c84a46dd04553 (patch)
tree2a2903ebf46d5622bab3e48040e721e60ea6e9cd /x11-libs/fox
parentUpdate e-mail :/ (diff)
downloadgentoo-2-fb6ce5ac68f3ebd18930ee3d6b7c84a46dd04553.tar.gz
gentoo-2-fb6ce5ac68f3ebd18930ee3d6b7c84a46dd04553.tar.bz2
gentoo-2-fb6ce5ac68f3ebd18930ee3d6b7c84a46dd04553.zip
version bump, includes jpeg-9 patch from jer@gentoo.org (bug #520674)
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xDDF971F118EEA5E6!)
Diffstat (limited to 'x11-libs/fox')
-rw-r--r--x11-libs/fox/ChangeLog8
-rw-r--r--x11-libs/fox/files/jpeg-9.patch40
-rw-r--r--x11-libs/fox/fox-1.7.49.ebuild60
3 files changed, 107 insertions, 1 deletions
diff --git a/x11-libs/fox/ChangeLog b/x11-libs/fox/ChangeLog
index d796d9b701ec..b771cc8e311a 100644
--- a/x11-libs/fox/ChangeLog
+++ b/x11-libs/fox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/fox
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.187 2014/07/04 21:23:34 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.188 2014/11/11 21:07:26 mabi Exp $
+
+*fox-1.7.49 (11 Nov 2014)
+
+ 11 Nov 2014; Matti Bickel <mabi@gentoo.org> +files/jpeg-9.patch,
+ +fox-1.7.49.ebuild:
+ version bump, includes jpeg-9 patch from jer@gentoo.org (bug #520674)
04 Jul 2014; Matti Bickel <mabi@gentoo.org> -fox-1.7.44.ebuild:
remove old
diff --git a/x11-libs/fox/files/jpeg-9.patch b/x11-libs/fox/files/jpeg-9.patch
new file mode 100644
index 000000000000..8075f03251c1
--- /dev/null
+++ b/x11-libs/fox/files/jpeg-9.patch
@@ -0,0 +1,40 @@
+--- a/lib/fxjpegio.cpp
++++ b/lib/fxjpegio.cpp
+@@ -138,7 +138,7 @@
+ src->pub.next_input_byte=src->buffer;
+ src->pub.bytes_in_buffer=1;
+ }
+- return true;
++ return TRUE;
+ }
+
+
+@@ -216,7 +216,7 @@
+ srcinfo.src=&src.pub;
+
+ // read the header from the jpg;
+- jpeg_read_header(&srcinfo,true);
++ jpeg_read_header(&srcinfo,TRUE);
+
+ // make sure the output is RGB
+ srcinfo.out_color_space=JCS_RGB;
+@@ -279,7 +279,7 @@
+ dest->stream->save(dest->buffer,JPEG_BUFFER_SIZE);
+ dest->pub.free_in_buffer=JPEG_BUFFER_SIZE;
+ dest->pub.next_output_byte=dest->buffer;
+- return true;
++ return TRUE;
+ }
+
+
+@@ -336,8 +336,8 @@
+ dstinfo.dest=&dst.pub;
+
+ jpeg_set_defaults(&dstinfo);
+- jpeg_set_quality(&dstinfo,quality,true);
+- jpeg_start_compress(&dstinfo,true);
++ jpeg_set_quality(&dstinfo,quality,TRUE);
++ jpeg_start_compress(&dstinfo,TRUE);
+
+ // Write the jpeg data
+ pp=data;
diff --git a/x11-libs/fox/fox-1.7.49.ebuild b/x11-libs/fox/fox-1.7.49.ebuild
new file mode 100644
index 000000000000..78c7d1177fb3
--- /dev/null
+++ b/x11-libs/fox/fox-1.7.49.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.7.49.ebuild,v 1.1 2014/11/11 21:07:26 mabi Exp $
+
+EAPI=5
+
+inherit fox
+
+LICENSE="LGPL-2.1"
+SLOT="1.7"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+bzip2 +jpeg +opengl +png tiff +truetype +zlib"
+
+# newish autoconf needed for working mmap check
+RDEPEND="x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/fox-wrapper
+ >=sys-devel/autoconf-2.67
+ bzip2? ( app-arch/bzip2 )
+ jpeg? ( virtual/jpeg )
+ opengl? ( virtual/glu virtual/opengl )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+ truetype? ( media-libs/freetype:2
+ x11-libs/libXft )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-libs/libXt"
+
+src_prepare() {
+ fox_src_prepare
+ epatch "${FILESDIR}/jpeg-9.patch"
+}
+
+src_configure() {
+ FOXCONF="$(use_enable bzip2 bz2lib) \
+ $(use_enable jpeg) \
+ $(use_with opengl) \
+ $(use_enable png) \
+ $(use_enable tiff) \
+ $(use_with truetype xft) \
+ $(use_enable zlib)" fox_src_configure
+}
+
+src_install() {
+ fox_src_install
+ CP="${ED}/usr/bin/ControlPanel"
+ if [[ -f ${CP} ]] ; then
+ mv "${CP}" "${ED}/usr/bin/fox-ControlPanel-${SLOT}" || \
+ die "Failed to install ControlPanel"
+ fi
+}
+
+pkg_postinst() {
+ fox_pkg_postinst
+
+ einfo "ControlPanel has been installed to 'fox-ControlPanel-${SLOT}' to avoid conflicts"
+ einfo "with other packages."
+}