summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-28 04:29:34 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-28 04:29:34 +0000
commitf2dc6d26b70d8d70157a17279b8761d990d467c0 (patch)
tree66051d6fb98042ab025907f4c33d0f35dec08c77 /x11-libs/gtkDPS/gtkDPS-0.3.3-r1.ebuild
parentRedhat Skipjack beta2 kernel sources (diff)
downloadgentoo-2-f2dc6d26b70d8d70157a17279b8761d990d467c0.tar.gz
gentoo-2-f2dc6d26b70d8d70157a17279b8761d990d467c0.tar.bz2
gentoo-2-f2dc6d26b70d8d70157a17279b8761d990d467c0.zip
cleanup
Diffstat (limited to 'x11-libs/gtkDPS/gtkDPS-0.3.3-r1.ebuild')
-rw-r--r--x11-libs/gtkDPS/gtkDPS-0.3.3-r1.ebuild29
1 files changed, 14 insertions, 15 deletions
diff --git a/x11-libs/gtkDPS/gtkDPS-0.3.3-r1.ebuild b/x11-libs/gtkDPS/gtkDPS-0.3.3-r1.ebuild
index 5978d833bc4b..89cd257ea992 100644
--- a/x11-libs/gtkDPS/gtkDPS-0.3.3-r1.ebuild
+++ b/x11-libs/gtkDPS/gtkDPS-0.3.3-r1.ebuild
@@ -1,33 +1,32 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkDPS/gtkDPS-0.3.3-r1.ebuild,v 1.1 2001/10/06 10:08:19 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkDPS/gtkDPS-0.3.3-r1.ebuild,v 1.2 2002/04/28 04:29:34 seemant Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Set of functions, objects and widgets to use DPS easily with GTK"
-SRC_URI="http://www.aist-nara.ac.jp/~masata-y/gtkDPS/dist/${A}"
+SRC_URI="http://www.aist-nara.ac.jp/~masata-y/gtkDPS/dist/${P}.tar.gz"
HOMEPAGE="http://www.aist-nara.ac.jp/~masata-y/gtkDPS/"
-DEPEND="virtual/glibc nls? ( sys-devel/gettext )
+DEPEND="virtual/glibc
>=x11-libs/gtk+-1.2.10-r4
>=app-text/dgs-0.5.9.1"
-RDEPEND="virtual/glibc"
+
+RDEPEND="nls? ( sys-devel/gettext )"
src_compile() {
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
- try ./configure --prefix=/usr --host=${CHOST} \
- --with-x --with-dps $myconf
- try make
+ ./configure --prefix=/usr --host=${CHOST} \
+ --with-x --with-dps $myconf || die
+ make || die
}
src_install () {
- try make prefix=${D}/usr install
- dodoc COPYING* ChangeLog GTKDPS-VERSION HACKING NEWS README TODO
+ make prefix=${D}/usr install || die
+ dodoc COPYING* ChangeLog GTKDPS-VERSION HACKING NEWS README TODO
}
-