summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2008-11-05 18:24:54 +0000
committerSerkan Kaba <serkan@gentoo.org>2008-11-05 18:24:54 +0000
commit11da8917803bbcd684fe48a6a2525cdebcc856d2 (patch)
tree5ad5a4849f7e9b2fd67e13392a2462ad4732aa04 /x11-libs/gtkhotkey/gtkhotkey-0.2.0.ebuild
parentVersion cleanup, and version bump. Should address bug 224571 and bug 240052 (diff)
downloadgentoo-2-11da8917803bbcd684fe48a6a2525cdebcc856d2.tar.gz
gentoo-2-11da8917803bbcd684fe48a6a2525cdebcc856d2.tar.bz2
gentoo-2-11da8917803bbcd684fe48a6a2525cdebcc856d2.zip
Initial import based on ebuild by Mikel Olasagasti <hey_neken@mundurat.net>. Fixes bug #245153.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'x11-libs/gtkhotkey/gtkhotkey-0.2.0.ebuild')
-rw-r--r--x11-libs/gtkhotkey/gtkhotkey-0.2.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-libs/gtkhotkey/gtkhotkey-0.2.0.ebuild b/x11-libs/gtkhotkey/gtkhotkey-0.2.0.ebuild
new file mode 100644
index 000000000000..384896a4abab
--- /dev/null
+++ b/x11-libs/gtkhotkey/gtkhotkey-0.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkhotkey/gtkhotkey-0.2.0.ebuild,v 1.1 2008/11/05 18:24:54 serkan Exp $
+
+inherit versionator
+
+MY_CRV=$(get_version_component_range 1-2)
+
+DESCRIPTION="Cross platform library for using desktop wide hotkeys"
+HOMEPAGE="http://launchpad.net/gtkhotkey"
+SRC_URI="http://launchpad.net/${PN}/${MY_CRV}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=dev-libs/glib-2.16
+ >=x11-libs/gtk+-2.12"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}
+