summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-11-25 17:42:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-11-25 17:42:50 +0000
commitf7238ef36622af8745d03ba0412810ff2876db4c (patch)
treee8b015fc2d83664e31493e2877576f43ef7d66c0 /x11-libs/libQGLViewer
parentRemove upper bound on dev-python/paramiko dep, bug 528154. (diff)
downloadgentoo-2-f7238ef36622af8745d03ba0412810ff2876db4c.tar.gz
gentoo-2-f7238ef36622af8745d03ba0412810ff2876db4c.tar.bz2
gentoo-2-f7238ef36622af8745d03ba0412810ff2876db4c.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'x11-libs/libQGLViewer')
-rw-r--r--x11-libs/libQGLViewer/ChangeLog7
-rw-r--r--x11-libs/libQGLViewer/libQGLViewer-2.6.0.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/x11-libs/libQGLViewer/ChangeLog b/x11-libs/libQGLViewer/ChangeLog
index be25505673a4..0738c7559b2e 100644
--- a/x11-libs/libQGLViewer/ChangeLog
+++ b/x11-libs/libQGLViewer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libQGLViewer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libQGLViewer/ChangeLog,v 1.4 2014/11/07 10:08:37 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libQGLViewer/ChangeLog,v 1.5 2014/11/25 17:42:50 aballier Exp $
+
+*libQGLViewer-2.6.0 (25 Nov 2014)
+
+ 25 Nov 2014; Alexis Ballier <aballier@gentoo.org> +libQGLViewer-2.6.0.ebuild:
+ version bump
*libQGLViewer-2.5.4 (07 Nov 2014)
diff --git a/x11-libs/libQGLViewer/libQGLViewer-2.6.0.ebuild b/x11-libs/libQGLViewer/libQGLViewer-2.6.0.ebuild
new file mode 100644
index 000000000000..c1fe67ca53c7
--- /dev/null
+++ b/x11-libs/libQGLViewer/libQGLViewer-2.6.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libQGLViewer/libQGLViewer-2.6.0.ebuild,v 1.1 2014/11/25 17:42:50 aballier Exp $
+
+EAPI="5"
+
+inherit qt4-r2 multilib flag-o-matic
+
+DESCRIPTION="C++ library based on Qt that eases the creation of OpenGL 3D viewers"
+HOMEPAGE="http://www.libqglviewer.com"
+SRC_URI="http://www.libqglviewer.com/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="designer examples"
+
+DEPEND="virtual/opengl
+ dev-qt/qtopengl:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}
+ designer? ( dev-qt/designer:4 )"
+
+src_configure() {
+ append-ldflags "-L${S}/QGLViewer"
+ sed -e 's#designerPlugin##' -i ${P}.pro || die
+ use examples || sed -e 's#examples examples/contribs##' -i ${P}.pro || die
+ eqmake4 ${P}.pro \
+ PREFIX="${EPREFIX}/usr" \
+ LIB_DIR="${EPREFIX}/usr/$(get_libdir)" \
+ DOC_DIR="${EPREFIX}/usr/share/doc/${PF}/html"
+ if use designer ; then
+ cd "${S}/designerPlugin"
+ eqmake4 designerPlugin.pro
+ fi
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ dodoc README
+
+ if use designer ; then
+ cd "${S}/designerPlugin"
+ emake INSTALL_ROOT="${D}" install
+ fi
+
+ if use examples ; then
+ exeinto /usr/bin/${PN}-examples
+ doexe $(find "${S}/examples" -type f -executable ! -name '*.vcproj')
+ fi
+}