summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-02 21:43:50 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-02 21:43:50 +0000
commit7284b7454b3e1624a2795847e2920395d6a70fe6 (patch)
treea254cc546b876e228e9d96ebab4fb9ac73269d3c /x11-libs/libjwc_f
parentMore bug references. (diff)
downloadgentoo-2-7284b7454b3e1624a2795847e2920395d6a70fe6.tar.gz
gentoo-2-7284b7454b3e1624a2795847e2920395d6a70fe6.tar.bz2
gentoo-2-7284b7454b3e1624a2795847e2920395d6a70fe6.zip
Another split library from ccp4
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libjwc_f')
-rw-r--r--x11-libs/libjwc_f/ChangeLog10
-rw-r--r--x11-libs/libjwc_f/files/612-gentoo.patch100
-rw-r--r--x11-libs/libjwc_f/libjwc_f-1.1-r1.ebuild35
-rw-r--r--x11-libs/libjwc_f/metadata.xml8
4 files changed, 153 insertions, 0 deletions
diff --git a/x11-libs/libjwc_f/ChangeLog b/x11-libs/libjwc_f/ChangeLog
new file mode 100644
index 000000000000..ba6665273c72
--- /dev/null
+++ b/x11-libs/libjwc_f/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-libs/libjwc_f
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libjwc_f/ChangeLog,v 1.1 2010/02/02 21:43:49 jlec Exp $
+
+*libjwc_f-1.1-r1 (02 Feb 2010)
+
+ 02 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +files/612-gentoo.patch, +libjwc_f-1.1-r1.ebuild, +metadata.xml:
+ Split library from ccp4 package
+
diff --git a/x11-libs/libjwc_f/files/612-gentoo.patch b/x11-libs/libjwc_f/files/612-gentoo.patch
new file mode 100644
index 000000000000..e687d8bec6ea
--- /dev/null
+++ b/x11-libs/libjwc_f/files/612-gentoo.patch
@@ -0,0 +1,100 @@
+diff -Nu libjwc_f-1.1/configure.in ccp4-6.1.2/x-windows/libjwc/libjwc_f/configure.in
+--- libjwc_f-1.1/configure.in 1999-10-21 16:07:14.000000000 +0200
++++ ccp4-6.1.2/x-windows/libjwc/libjwc_f/configure.in 2004-03-11 17:31:45.000000000 +0100
+@@ -8,6 +8,7 @@
+ AC_CANONICAL_SYSTEM
+
+ AM_INIT_AUTOMAKE(libjwc_f, 1.1)
++AM_MAINTAINER_MODE
+
+ case ${with_g77} in
+ "yes" ) CC="gcc" GCC=yes F77=g77 ;;
+@@ -17,7 +18,7 @@
+ AC_PROG_F77
+
+ AC_PROG_INSTALL
+-AC_PROG_RANLIB
++AC_PROG_LIBTOOL
+
+ case "$target" in
+ *irix6* )
+@@ -26,8 +27,9 @@
+ case "$FFLAGS" in
+ *-64* ) ;; # assume they meant it
+ *-o32* | *-32* ) ;; # presumably OK
+- * ) FFLAGS="$FFLAGS -o32 -O -g3"
+- CFLAGS=-32
++ *-n32* ) ;;
++ * ) FFLAGS="$FFLAGS -n32 -O -g3"
++ CFLAGS=-n32
+ AC_MSG_WARN([
+
+ *** Using compiler flag -o32 for probable compatibility with
+@@ -47,8 +49,33 @@
+ *** See the INSTALL file for more info.
+ ])
+ fi ;;
++ *linux* )
++ case $F77 in
++ g77*)
++ case "$FFLAGS" in
++ *no-second-underscore* ) ;; # presumably OK
++ * ) FFLAGS="$FFLAGS -fno-second-underscore -fno-globals" ;;
++ esac
++ esac ;;
++ *darwin* )
++ case $F77 in
++ g77*)
++ case "$FFLAGS" in
++ *no-second-underscore* ) ;; # presumably OK
++ * ) FFLAGS="$FFLAGS -fno-second-underscore -fno-globals" ;;
++ esac
++#mac g77 currently goes not handle -fno-common
++ enable_shared=no;
++ esac ;;
+ * )
+ esac
++# efc, version 7.1 at least does not support soname, so use CC
++case "$F77" in
++ *efc ) F77LD=${F77LD:-'${CC}'} ;;
++ * ) F77LD=${F77LD:-'${F77}'}
++esac
++
++AC_SUBST(F77LD)
+
+ AM_PROG_LIBTOOL
+
+Common subdirectories: libjwc_f-1.1/doc and ccp4-6.1.2/x-windows/libjwc/libjwc_f/doc
+diff -Nu libjwc_f-1.1/opn_scr.f ccp4-6.1.2/x-windows/libjwc/libjwc_f/opn_scr.f
+--- libjwc_f-1.1/opn_scr.f 1999-09-07 12:50:13.000000000 +0200
++++ ccp4-6.1.2/x-windows/libjwc/libjwc_f/opn_scr.f 2000-10-25 13:03:09.000000000 +0200
+@@ -16,6 +16,6 @@
+ C
+ C====== Open the file
+ C
+- OPEN (IUN_SCR, STATUS='SCRATCH')
+- RETURN
++C OPEN (IUN_SCR, STATUS='SCRATCH')
++ CALL CCPDPN(IUN_SCR,'JWCSCR','SCRATCH','U',0, IFAIL)
+ END
+diff -Nu libjwc_f-1.1/rpf_dstar.f ccp4-6.1.2/x-windows/libjwc/libjwc_f/rpf_dstar.f
+--- libjwc_f-1.1/rpf_dstar.f 1999-07-09 13:39:38.000000000 +0200
++++ ccp4-6.1.2/x-windows/libjwc/libjwc_f/rpf_dstar.f 2004-06-04 12:10:59.000000000 +0200
+@@ -376,7 +376,8 @@
+ INR_FLAG = 2
+ PHIW = 0.0
+ END IF
+- ELSE
++ RETURN
++ ENDIF
+ C
+ C---- Calculate distance of edge of spot from sphere at end of rotation
+ Crotgen.for
+@@ -418,7 +419,6 @@
+ INR_FLAG = 4
+ 40 RETURN
+ END IF
+- END IF
+ END IF
+ RETURN
+ END
diff --git a/x11-libs/libjwc_f/libjwc_f-1.1-r1.ebuild b/x11-libs/libjwc_f/libjwc_f-1.1-r1.ebuild
new file mode 100644
index 000000000000..3e74eace9352
--- /dev/null
+++ b/x11-libs/libjwc_f/libjwc_f-1.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libjwc_f/libjwc_f-1.1-r1.ebuild,v 1.1 2010/02/02 21:43:49 jlec Exp $
+
+EAPI="2"
+
+inherit autotools eutils fortran
+
+FORTRAN="g77 gfortran ifc"
+
+PATCH="612"
+
+DESCRIPTION="additional c library for ccp4"
+HOMEPAGE="http://www.ccp4.ac.uk/main.html"
+SRC_URI="ftp://ftp.ccp4.ac.uk/jwc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PATCH}-gentoo.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS README
+ dohtml doc/*
+}
diff --git a/x11-libs/libjwc_f/metadata.xml b/x11-libs/libjwc_f/metadata.xml
new file mode 100644
index 000000000000..efb490d78817
--- /dev/null
+++ b/x11-libs/libjwc_f/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>sci@gentoo.org</email>
+</maintainer>
+</pkgmetadata>