summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2014-01-26 19:09:19 +0000
committerMatt Turner <mattst88@gentoo.org>2014-01-26 19:09:19 +0000
commit48a60e99f1e72c3551b03d786842518b76433f91 (patch)
tree89e2c48f3604c3fd01348cb886d24cbc42d71766 /x11-libs/libxcb
parentVersion bump to 1.10, bug 496802. (diff)
downloadgentoo-2-48a60e99f1e72c3551b03d786842518b76433f91.tar.gz
gentoo-2-48a60e99f1e72c3551b03d786842518b76433f91.tar.bz2
gentoo-2-48a60e99f1e72c3551b03d786842518b76433f91.zip
Version bumped to 1.10, bug 496800.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 974CA72A)
Diffstat (limited to 'x11-libs/libxcb')
-rw-r--r--x11-libs/libxcb/ChangeLog7
-rw-r--r--x11-libs/libxcb/libxcb-1.10.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-libs/libxcb/ChangeLog b/x11-libs/libxcb/ChangeLog
index 9414456b47b4..da41c512ce9a 100644
--- a/x11-libs/libxcb/ChangeLog
+++ b/x11-libs/libxcb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libxcb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.128 2014/01/11 11:15:20 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/ChangeLog,v 1.129 2014/01/26 19:09:19 mattst88 Exp $
+
+*libxcb-1.10 (26 Jan 2014)
+
+ 26 Jan 2014; Matt Turner <mattst88@gentoo.org> +libxcb-1.10.ebuild:
+ Version bumped to 1.10, bug 496800.
*libxcb-1.9.3-r1 (11 Jan 2014)
diff --git a/x11-libs/libxcb/libxcb-1.10.ebuild b/x11-libs/libxcb/libxcb-1.10.ebuild
new file mode 100644
index 000000000000..f230b2a4228f
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.10.ebuild,v 1.1 2014/01/26 19:09:19 mattst88 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+PYTHON_REQ_USE=xml
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit python-any-r1 xorg-2
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/libxcb"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="selinux xkb"
+
+RDEPEND="dev-libs/libpthread-stubs[${MULTILIB_USEDEP}]
+ x11-libs/libXau[${MULTILIB_USEDEP}]
+ x11-libs/libXdmcp[${MULTILIB_USEDEP}]"
+# Note: ${PYTHON_USEDEP} needs to go verbatim
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ $(python_gen_any_dep \
+ ">=x11-proto/xcb-proto-1.10[${MULTILIB_USEDEP},\${PYTHON_USEDEP}]")"
+
+python_check_deps() {
+ has_version ">=x11-proto/xcb-proto-1.10[${MULTILIB_USEDEP},${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc build-docs)
+ $(use_enable selinux)
+ $(use_enable xkb)
+ --enable-xinput
+ )
+ xorg-2_src_configure
+}