summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-08-29 15:12:27 +0000
committerNick Hadaway <raker@gentoo.org>2002-08-29 15:12:27 +0000
commitdc7abf54498f8aadd33bbe219577b8db50532e8f (patch)
tree9459b8f6bff00d5fc206a229438b18e29f4d65a8 /x11-libs/openmotif/openmotif-2.2.2-r1.ebuild
parentadd value 5 to min-kde-ver() version case statement; fix problem with ebuilds... (diff)
downloadgentoo-2-dc7abf54498f8aadd33bbe219577b8db50532e8f.tar.gz
gentoo-2-dc7abf54498f8aadd33bbe219577b8db50532e8f.tar.bz2
gentoo-2-dc7abf54498f8aadd33bbe219577b8db50532e8f.zip
Updated ebuild to install in /usr/X11R6 instead of /usr.
openmotif-2.2.2 does not overwrite xmkmf and imake like openmotif-2.1.30 did. Users who need these files must re-emerge xfree.
Diffstat (limited to 'x11-libs/openmotif/openmotif-2.2.2-r1.ebuild')
-rw-r--r--x11-libs/openmotif/openmotif-2.2.2-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-libs/openmotif/openmotif-2.2.2-r1.ebuild b/x11-libs/openmotif/openmotif-2.2.2-r1.ebuild
new file mode 100644
index 000000000000..e2fe03dbe09f
--- /dev/null
+++ b/x11-libs/openmotif/openmotif-2.2.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.2.2-r1.ebuild,v 1.1 2002/08/29 15:12:27 raker Exp $
+
+S=${WORKDIR}/openMotif-2.2.2
+
+DESCRIPTION="Open Motif"
+SRC_URI="ftp://ftp.sgi.com/other/motifzone/2.2/src/openMotif-2.2.2.tar.gz"
+HOMEPAGE="http://www.motifzone.org/"
+
+LICENSE="MOTIF"
+SLOT="0"
+KEYWORDS="x86 ppc -sparc -sparc64"
+
+DEPEND="virtual/glibc
+ virtual/x11"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/animate-demo.diff || die "patch failed"
+ patch -p1 < ${FILESDIR}/include-order.diff || die "patch failed"
+}
+
+src_compile() {
+
+ ./configure \
+ --prefix=/usr/X11R6 \
+ --sysconfdir=/etc/X11 \
+ --with-x \
+ --with-gnu-ld \
+ --host=${CHOST} || die "configuration failed"
+
+ make || die "make failed"
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} VARDIR=${D}/var/X11/ install || die "install failed"
+
+}