summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-29 21:25:57 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-29 21:25:57 +0000
commit19f0accf8c83514cae83788bf97c9be46c45d2c9 (patch)
treef15e7096888675b7f26b0406ff19dd9258d291d3 /x11-libs/pango/files
parentNew version for GNOME 2.28. Clean up old revision. (diff)
downloadgentoo-2-19f0accf8c83514cae83788bf97c9be46c45d2c9.tar.gz
gentoo-2-19f0accf8c83514cae83788bf97c9be46c45d2c9.tar.bz2
gentoo-2-19f0accf8c83514cae83788bf97c9be46c45d2c9.zip
New version for GNOME 2.28. Clean up old revisions.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/pango/files')
-rw-r--r--x11-libs/pango/files/pango-1.26.0-introspection-automagic.patch214
-rw-r--r--x11-libs/pango/files/pango-1.26.0-lib64.patch20
2 files changed, 234 insertions, 0 deletions
diff --git a/x11-libs/pango/files/pango-1.26.0-introspection-automagic.patch b/x11-libs/pango/files/pango-1.26.0-introspection-automagic.patch
new file mode 100644
index 000000000000..b699b176c094
--- /dev/null
+++ b/x11-libs/pango/files/pango-1.26.0-introspection-automagic.patch
@@ -0,0 +1,214 @@
+Use the introspection.m4 macro for checking for introspection. Fixes automagic,
+and keeps variable name consistency across modules.
+
+---
+--- configure.in
++++ configure.in
+@@ -58,6 +58,7 @@
+ AM_INIT_AUTOMAKE(1.9 gnits dist-bzip2 no-dist-gzip -Wno-portability)
+ m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
+ AM_CONFIG_HEADER([config.h])
++AC_CONFIG_MACRO_DIR([m4])
+
+
+ PANGO_VERSION_MAJOR=pango_version_major()
+@@ -493,27 +494,7 @@
+ #
+ # Checks for GObject Introspection
+ #
+-have_introspection=false
+-PKG_CHECK_MODULES(INTROSPECTION, gobject-introspection-1.0 >= 0.6.4, have_introspection=true, have_introspection=false)
+-AM_CONDITIONAL(HAVE_INTROSPECTION, $have_introspection)
+-
+-G_IR_SCANNER=
+-G_IR_COMPILER=
+-G_IR_GENERATE=
+-GIRDIR=
+-TYPELIBDIR=
+-if $have_introspection; then
+- G_IR_SCANNER=`$PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0`
+- G_IR_COMPILER=`$PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0`
+- G_IR_GENERATE=`$PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0`
+- GIRDIR=`$PKG_CONFIG --variable=girdir gobject-introspection-1.0`
+- TYPELIBDIR="$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)"
+-fi
+-AC_SUBST(G_IR_SCANNER)
+-AC_SUBST(G_IR_COMPILER)
+-AC_SUBST(G_IR_GENERATE)
+-AC_SUBST(GIRDIR)
+-AC_SUBST(TYPELIBDIR)
++GOBJECT_INTROSPECTION_CHECK(0.6.4)
+
+ #
+ # Modules to build
+--- m4/introspection.m4
++++ m4/introspection.m4
+@@ -0,0 +1,92 @@
++dnl -*- mode: autoconf -*-
++dnl Copyright 2009 Johan Dahlin
++dnl
++dnl This file is free software; the author(s) gives unlimited
++dnl permission to copy and/or distribute it, with or without
++dnl modifications, as long as this notice is preserved.
++dnl
++
++# serial 1
++
++m4_define([_GOBJECT_INTROSPECTION_CHECK_INTERNAL],
++[
++ AC_BEFORE([AC_PROG_LIBTOOL],[$0])dnl setup libtool first
++ AC_BEFORE([AM_PROG_LIBTOOL],[$0])dnl setup libtool first
++ AC_BEFORE([LT_INIT],[$0])dnl setup libtool first
++
++ dnl enable/disable introspection
++ m4_if([$2], [require],
++ [dnl
++ enable_introspection=yes
++ ],[dnl
++ AC_ARG_ENABLE(introspection,
++ AS_HELP_STRING([--enable-introspection[=@<:@no/auto/yes@:>@]],
++ [Enable introspection for this build]),,
++ [enable_introspection=auto])
++ ])dnl
++
++ AC_MSG_CHECKING([for gobject-introspection])
++
++ dnl presence/version checking
++ AS_CASE([$enable_introspection],
++ [no], [dnl
++ found_introspection="no (disabled, use --enable-introspection to enable)"
++ ],dnl
++ [yes],[dnl
++ PKG_CHECK_EXISTS([gobject-introspection-1.0],,
++ AC_MSG_ERROR([gobject-introspection-1.0 is not installed]))
++ PKG_CHECK_EXISTS([gobject-introspection-1.0 >= $1],
++ found_introspection=yes,
++ AC_MSG_ERROR([You need to have gobject-introspection >= $1 installed to build AC_PACKAGE_NAME]))
++ ],dnl
++ [auto],[dnl
++ PKG_CHECK_EXISTS([gobject-introspection-1.0 >= $1], found_introspection=yes, found_introspection=no)
++ ],dnl
++ [dnl
++ AC_MSG_ERROR([invalid argument passed to --enable-introspection, should be one of @<:@no/auto/yes@:>@])
++ ])dnl
++
++ AC_MSG_RESULT([$found_introspection])
++
++ INTROSPECTION_SCANNER=
++ INTROSPECTION_COMPILER=
++ INTROSPECTION_GENERATE=
++ INTROSPECTION_GIRDIR=
++ INTROSPECTION_TYPELIBDIR=
++ if test "x$found_introspection" = "xyes"; then
++ INTROSPECTION_SCANNER=`$PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0`
++ INTROSPECTION_COMPILER=`$PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0`
++ INTROSPECTION_GENERATE=`$PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0`
++ INTROSPECTION_GIRDIR=`$PKG_CONFIG --variable=girdir gobject-introspection-1.0`
++ INTROSPECTION_TYPELIBDIR="$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)"
++ INTROSPECTION_CFLAGS=`$PKG_CONFIG --cflags gobject-introspection-1.0`
++ INTROSPECTION_LIBS=`$PKG_CONFIG --libs gobject-introspection-1.0`
++ fi
++ AC_SUBST(INTROSPECTION_SCANNER)
++ AC_SUBST(INTROSPECTION_COMPILER)
++ AC_SUBST(INTROSPECTION_GENERATE)
++ AC_SUBST(INTROSPECTION_GIRDIR)
++ AC_SUBST(INTROSPECTION_TYPELIBDIR)
++ AC_SUBST(INTROSPECTION_CFLAGS)
++ AC_SUBST(INTROSPECTION_LIBS)
++
++ AM_CONDITIONAL(HAVE_INTROSPECTION, test "x$found_introspection" = "xyes")
++])
++
++
++dnl Usage:
++dnl GOBJECT_INTROSPECTION_CHECK([minimum-g-i-version])
++
++AC_DEFUN([GOBJECT_INTROSPECTION_CHECK],
++[
++ _GOBJECT_INTROSPECTION_CHECK_INTERNAL([$1])
++])
++
++dnl Usage:
++dnl GOBJECT_INTROSPECTION_REQUIRE([minimum-g-i-version])
++
++
++AC_DEFUN([GOBJECT_INTROSPECTION_REQUIRE],
++[
++ _GOBJECT_INTROSPECTION_CHECK_INTERNAL([$1], [require])
++])
+--- Makefile.am
++++ Makefile.am
+@@ -2,6 +2,8 @@
+
+ SUBDIRS= pango modules pango-view examples docs tools tests
+
++ACLOCAL_AMFLAGS = -I m4 -I .
++
+ EXTRA_DIST = \
+ autogen.sh \
+ pango.pc.in \
+--- pango/Makefile.am
++++ pango/Makefile.am
+@@ -163,8 +163,8 @@
+ Pango-1.0.gir: $(libpango_1_0_la_SOURCES)
+ Pango-1.0.gir: $(pango_headers)
+ Pango-1.0.gir: libpango-1.0.la
+-Pango-1.0.gir: $(G_IR_SCANNER) Makefile
+- $(AM_V_GEN) $(G_IR_SCANNER) -v --namespace Pango --nsversion=1.0 \
++Pango-1.0.gir: $(INTROSPECTION_SCANNER) Makefile
++ $(AM_V_GEN) $(INTROSPECTION_SCANNER) -v --namespace Pango --nsversion=1.0 \
+ --add-include-path=$(srcdir) --add-include-path=. \
+ --include=GObject-2.0 \
+ --include=cairo-1.0 \
+@@ -278,8 +278,8 @@
+ PangoFT2-1.0.gir: $(pangoft2_headers)
+ PangoFT2-1.0.gir: $(libpangoft2_1_0_la_SOURCES)
+ PangoFT2-1.0.gir: libpangoft2-1.0.la
+-PangoFT2-1.0.gir: Pango-1.0.gir $(G_IR_SCANNER) Makefile
+- $(AM_V_GEN) $(G_IR_SCANNER) -v --namespace PangoFT2 --nsversion=1.0 \
++PangoFT2-1.0.gir: Pango-1.0.gir $(INTROSPECTION_SCANNER) Makefile
++ $(AM_V_GEN) $(INTROSPECTION_SCANNER) -v --namespace PangoFT2 --nsversion=1.0 \
+ --add-include-path=$(srcdir) --add-include-path=. \
+ --include=GObject-2.0 \
+ --include=Pango-1.0 \
+@@ -335,8 +335,8 @@
+ PangoXft-1.0.gir: $(pangoxft_headers)
+ PangoXft-1.0.gir: $(libpangoxft_1_0_la_SOURCES)
+ PangoXft-1.0.gir: libpangoxft-1.0.la
+-PangoXft-1.0.gir: Pango-1.0.gir PangoFT2-1.0.gir $(G_IR_SCANNER) Makefile
+- $(AM_V_GEN) $(G_IR_SCANNER) -v --namespace PangoXft --nsversion=1.0 \
++PangoXft-1.0.gir: Pango-1.0.gir PangoFT2-1.0.gir $(INTROSPECTION_SCANNER) Makefile
++ $(AM_V_GEN) $(INTROSPECTION_SCANNER) -v --namespace PangoXft --nsversion=1.0 \
+ --add-include-path=$(srcdir) --add-include-path=. \
+ --include=GObject-2.0 \
+ --include=xft-2.0 \
+@@ -424,8 +424,8 @@
+ PangoCairo-1.0.gir: $(libpangocairo_1_0_la_SOURCES)
+ PangoCairo-1.0.gir: $(pangocairo_headers)
+ PangoCairo-1.0.gir: libpangocairo-1.0.la
+-PangoCairo-1.0.gir: Pango-1.0.gir $(PANGOCAIRO_FONT_BACKEND_GI_MODULE).gir $(G_IR_SCANNER) Makefile
+- $(AM_V_GEN) $(G_IR_SCANNER) -v --namespace PangoCairo --nsversion=1.0 \
++PangoCairo-1.0.gir: Pango-1.0.gir $(PANGOCAIRO_FONT_BACKEND_GI_MODULE).gir $(INTROSPECTION_SCANNER) Makefile
++ $(AM_V_GEN) $(INTROSPECTION_SCANNER) -v --namespace PangoCairo --nsversion=1.0 \
+ --add-include-path=$(srcdir) --add-include-path=. \
+ --include=GObject-2.0 \
+ --include=cairo-1.0 \
+@@ -551,14 +551,14 @@
+
+ if HAVE_INTROSPECTION
+
+-girdir = $(GIRDIR)
++girdir = $(INTROSPECTION_GIRDIR)
+ gir_DATA = $(BUILT_GIRSOURCES)
+
+-typelibsdir = $(TYPELIBDIR)
++typelibsdir = $(INTROSPECTION_TYPELIBDIR)
+ typelibs_DATA = $(BUILT_GIRSOURCES:.gir=.typelib)
+
+-%.typelib: %.gir $(G_IR_COMPILER)
+- $(AM_V_GEN) LD_LIBRARY_PATH=$${LD_LIBRARY_PATH:+$$LD_LIBRARY_PATH:}. $(G_IR_COMPILER) --includedir=$(srcdir) --includedir=. $(G_IR_COMPILER_OPTS) $< -o $(builddir)/$(@F)
++%.typelib: %.gir $(INTROSPECTION_COMPILER)
++ $(AM_V_GEN) LD_LIBRARY_PATH=$${LD_LIBRARY_PATH:+$$LD_LIBRARY_PATH:}. $(INTROSPECTION_COMPILER) --includedir=$(srcdir) --includedir=. $(INTROSPECTION_COMPILER_OPTS) $< -o $(builddir)/$(@F)
+
+ endif # HAVE_INTROSPECTION
+
diff --git a/x11-libs/pango/files/pango-1.26.0-lib64.patch b/x11-libs/pango/files/pango-1.26.0-lib64.patch
new file mode 100644
index 000000000000..cdbdd5024e28
--- /dev/null
+++ b/x11-libs/pango/files/pango-1.26.0-lib64.patch
@@ -0,0 +1,20 @@
+--- pango/Makefile.am
++++ pango/Makefile.am
+@@ -16,6 +16,7 @@
+ -DPANGO_ENABLE_BACKEND \
+ -DPANGO_ENABLE_ENGINE \
+ -DSYSCONFDIR=\"$(sysconfdir)\" \
++ -DHOST=\"$(host_triplet)\" \
+ -DLIBDIR=\"$(libdir)\" \
+ -DMODULE_VERSION=\"$(PANGO_MODULE_VERSION)\" \
+ -DG_DISABLE_DEPRECATED \
+--- pango/modules.c
++++ pango/modules.c
+@@ -353,6 +353,7 @@
+
+ if (!file_str)
+ file_str = g_build_filename (pango_get_sysconf_subdirectory (),
++ HOST,
+ "pango.modules",
+ NULL);
+