summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-12-22 18:18:39 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-12-22 18:18:39 +0000
commit1bb8d3a38997d7d2a4078574ce69c3a5827c6497 (patch)
treea0f9efd5fa92cf1b276aac9860f399ff5ea4b111 /x11-libs/qt-opengl
parentRemove old revision wrt bug #201682. (diff)
downloadgentoo-2-1bb8d3a38997d7d2a4078574ce69c3a5827c6497.tar.gz
gentoo-2-1bb8d3a38997d7d2a4078574ce69c3a5827c6497.tar.bz2
gentoo-2-1bb8d3a38997d7d2a4078574ce69c3a5827c6497.zip
Use new eclass functions
(Portage version: 2.1.3.16)
Diffstat (limited to 'x11-libs/qt-opengl')
-rw-r--r--x11-libs/qt-opengl/qt-opengl-4.4.0_rc1.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/x11-libs/qt-opengl/qt-opengl-4.4.0_rc1.ebuild b/x11-libs/qt-opengl/qt-opengl-4.4.0_rc1.ebuild
index a0a2fd573bd7..f06ac89cecb3 100644
--- a/x11-libs/qt-opengl/qt-opengl-4.4.0_rc1.ebuild
+++ b/x11-libs/qt-opengl/qt-opengl-4.4.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/qt-opengl-4.4.0_rc1.ebuild,v 1.6 2007/12/21 22:37:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/qt-opengl-4.4.0_rc1.ebuild,v 1.7 2007/12/22 18:18:39 caleb Exp $
inherit qt4-build
@@ -22,6 +22,8 @@ RDEPEND="~x11-libs/qt-gui-${PV}
DEPEND="${RDEPEND}"
+QT4_TARGET_DIRECTORIES="src/opengl"
+
src_unpack() {
qt4-build_src_unpack
@@ -44,14 +46,9 @@ src_compile() {
echo ./configure ${myconf}
./configure ${myconf} || die
- build_directories src/opengl
- # Not building tools/designer/src/plugins/tools/view3d as it's commented out of the build in the source
-}
+ build_target_directories
-src_install() {
- install_directories src/opengl
-
- fix_library_files
+ # Not building tools/designer/src/plugins/tools/view3d as it's commented out of the build in the source
}
pkg_postinst()