summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-10-30 18:18:37 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-10-30 18:18:37 +0000
commitc3cb965a6f1a15d686cb89ecdd9290d41899b56c (patch)
treef4cf9c0fe28d18bd8fbaf9ddd7a385d2c603b976 /x11-libs/qt/qt-4.2.1.ebuild
parentUse the workdir copy of buildbot for epydoc and trial, not the installed one.... (diff)
downloadgentoo-2-c3cb965a6f1a15d686cb89ecdd9290d41899b56c.tar.gz
gentoo-2-c3cb965a6f1a15d686cb89ecdd9290d41899b56c.tar.bz2
gentoo-2-c3cb965a6f1a15d686cb89ecdd9290d41899b56c.zip
Fix icc compiler detection per bug #152385 and add checking into the 4.2 series that is in the 4.1 series
(Portage version: 2.1.2_pre3-r7)
Diffstat (limited to 'x11-libs/qt/qt-4.2.1.ebuild')
-rw-r--r--x11-libs/qt/qt-4.2.1.ebuild33
1 files changed, 26 insertions, 7 deletions
diff --git a/x11-libs/qt/qt-4.2.1.ebuild b/x11-libs/qt/qt-4.2.1.ebuild
index 1bc87219cbc6..8f11dbe67a0d 100644
--- a/x11-libs/qt/qt-4.2.1.ebuild
+++ b/x11-libs/qt/qt-4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.2.1.ebuild,v 1.2 2006/10/30 17:49:15 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.2.1.ebuild,v 1.3 2006/10/30 18:18:37 caleb Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -71,14 +71,33 @@ qt_use() {
}
qt_mkspecs_dir() {
- # Allows us to define which mkspecs dir we want to use. Currently we only use
- # linux-g++ or linux-g++-64, but others could be used for various platforms.
-
- if [[ $(get_libdir) == "lib" ]]; then
- echo "linux-g++"
+ # Allows us to define which mkspecs dir we want to use.
+ local spec
+
+ case ${CHOST} in
+ *-freebsd*|*-dragonfly*)
+ spec="freebsd" ;;
+ *-openbsd*)
+ spec="openbsd" ;;
+ *-netbsd*)
+ spec="netbsd" ;;
+ *-darwin*)
+ spec="darwin" ;;
+ *-linux-*|*-linux)
+ spec="linux" ;;
+ *)
+ die "Unknown CHOST, no platform choosed."
+ esac
+
+ CXX=$(tc-getCXX)
+ if [[ ${CXX/g++/} != ${CXX} ]]; then
+ spec="${spec}-g++"
+ elif [[ ${CXX/icpc/} != ${CXX} ]]; then
+ spec="${spec}-icc"
else
- echo "linux-g++-64"
+ die "Unknown compiler ${CXX}."
fi
+
}
src_unpack() {