summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2009-08-02 21:54:28 +0000
committerThomas Sachau <tommy@gentoo.org>2009-08-02 21:54:28 +0000
commit8fb731b50d0813424bc7948bbc6792848474f87a (patch)
tree7bcf5cb2186dcedfae8343effbc8a5734e5e3855 /x11-libs/qt
parentold (diff)
downloadgentoo-2-8fb731b50d0813424bc7948bbc6792848474f87a.tar.gz
gentoo-2-8fb731b50d0813424bc7948bbc6792848474f87a.tar.bz2
gentoo-2-8fb731b50d0813424bc7948bbc6792848474f87a.zip
Enable multilib support for qt-3.3.8b-r{1,2}
(Portage version: 2.2_rc33-r5/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt')
-rw-r--r--x11-libs/qt/ChangeLog6
-rw-r--r--x11-libs/qt/qt-3.3.8b-r1.ebuild22
-rw-r--r--x11-libs/qt/qt-3.3.8b-r2.ebuild18
3 files changed, 23 insertions, 23 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index a5c9fdcfc280..3808a063dff2 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.585 2009/06/27 19:30:37 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.586 2009/08/02 21:54:28 tommy Exp $
+
+ 02 Aug 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ qt-3.3.8b-r1.ebuild, qt-3.3.8b-r2.ebuild:
+ Enable multilib support for qt-3.3.8b-r{1,2}
*qt-4.5.2 (27 Jun 2009)
diff --git a/x11-libs/qt/qt-3.3.8b-r1.ebuild b/x11-libs/qt/qt-3.3.8b-r1.ebuild
index d98651b26deb..8218e7688720 100644
--- a/x11-libs/qt/qt-3.3.8b-r1.ebuild
+++ b/x11-libs/qt/qt-3.3.8b-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.3.8b-r1.ebuild,v 1.7 2009/01/17 16:41:01 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.3.8b-r1.ebuild,v 1.8 2009/08/02 21:54:28 tommy Exp $
# *** Please remember to update qt3.eclass when revbumping this ***
@@ -51,8 +51,6 @@ S="${WORKDIR}/qt-x11-${SRCTYPE}-${PV}"
QTBASE="/usr/qt/3"
-libdir="$(get_libdir)"
-
pkg_setup() {
if use immqt && use immqt-bc ; then
ewarn
@@ -167,8 +165,8 @@ src_unpack() {
-e "s:\<QMAKE_LINK_SHLIB\>.*=.*:QMAKE_LINK_SHLIB=$(tc-getCXX):" \
"${S}"/mkspecs/${PLATFORM}/qmake.conf || die
- if [ ${libdir} != "lib" ] ; then
- sed -i -e "s:/lib$:/${libdir}:" \
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e "s:/lib$:/$(get_libdir):" \
"${S}"/mkspecs/${PLATFORM}/qmake.conf || die
fi
@@ -185,12 +183,12 @@ src_compile() {
addwrite "${QTBASE}/etc/settings"
addwrite "${HOME}/.qt"
- [ "${libdir}" != "lib" ] && myconf="${myconf} -L/usr/${libdir}"
+ [ "$(get_libdir)" != "lib" ] && myconf="${myconf} -L/usr/$(get_libdir)"
# unixODBC support is now a PDEPEND on dev-db/qt-unixODBC; see bug 14178.
use nas && myconf+=" -system-nas-sound"
use nis && myconf+=" -nis" || myconf+=" -no-nis"
- use mysql && myconf+=" -plugin-sql-mysql -I/usr/include/mysql -L/usr/${libdir}/mysql" || myconf+=" -no-sql-mysql"
+ use mysql && myconf+=" -plugin-sql-mysql -I/usr/include/mysql -L/usr/$(get_libdir)/mysql" || myconf+=" -no-sql-mysql"
use postgres && myconf+=" -plugin-sql-psql -I/usr/include/postgresql/server -I/usr/include/postgresql/pgsql -I/usr/include/postgresql/pgsql/server" || myconf+=" -no-sql-psql"
use firebird && myconf+=" -plugin-sql-ibase -I/opt/firebird/include" || myconf+=" -no-sql-ibase"
use sqlite && myconf+=" -plugin-sql-sqlite" || myconf+=" -no-sql-sqlite"
@@ -212,7 +210,7 @@ src_compile() {
./configure -sm -thread -stl -system-libjpeg -verbose -largefile \
-qt-imgfmt-{jpeg,mng,png} -tablet -system-libmng \
-system-libpng -xft -platform ${PLATFORM} -xplatform \
- ${PLATFORM} -xrender -prefix ${QTBASE} -libdir ${QTBASE}/${libdir} \
+ ${PLATFORM} -xrender -prefix ${QTBASE} -libdir ${QTBASE}/$(get_libdir) \
-fast -no-sql-odbc ${myconf} -dlopen-opengl || die
emake src-qmake src-moc sub-src || die
@@ -249,7 +247,7 @@ src_install() {
dolib.so lib/lib{editor,qassistantclient,designercore}.a
dolib.so lib/libqt-mt.la
dolib.so lib/libqt-mt.so.${PV/b} lib/libqui.so.1.0.0
- cd "${D}"/${QTBASE}/${libdir}
+ cd "${D}"/${QTBASE}/$(get_libdir)
for x in libqui.so ; do
ln -s $x.1.0.0 $x.1.0
@@ -287,11 +285,11 @@ src_install() {
# prl files
sed -i -e "s:${S}:${QTBASE}:g" "${S}"/lib/*.prl
- insinto ${QTBASE}/${libdir}
+ insinto ${QTBASE}/$(get_libdir)
doins "${S}"/lib/*.prl
# pkg-config file
- insinto ${QTBASE}/${libdir}/pkgconfig
+ insinto ${QTBASE}/$(get_libdir)/pkgconfig
doins "${S}"/lib/*.pc
# List all the multilib libdirs
@@ -307,7 +305,7 @@ ROOTPATH=${QTBASE}/bin
LDPATH=${libdirs:1}
QMAKESPEC=${PLATFORM}
MANPATH=${QTBASE}/doc/man
-PKG_CONFIG_PATH=${QTBASE}/${libdir}/pkgconfig
+PKG_CONFIG_PATH=${QTBASE}/$(get_libdir)/pkgconfig
EOF
cat <<EOF > "${T}"/50qtdir3
diff --git a/x11-libs/qt/qt-3.3.8b-r2.ebuild b/x11-libs/qt/qt-3.3.8b-r2.ebuild
index d9de1737a49f..4eb6247ad0f9 100644
--- a/x11-libs/qt/qt-3.3.8b-r2.ebuild
+++ b/x11-libs/qt/qt-3.3.8b-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.3.8b-r2.ebuild,v 1.1 2009/06/11 20:46:10 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.3.8b-r2.ebuild,v 1.2 2009/08/02 21:54:28 tommy Exp $
# *** Please remember to update qt3.eclass when revbumping this ***
@@ -51,8 +51,6 @@ S="${WORKDIR}/qt-x11-${SRCTYPE}-${PV}"
QTBASE="/usr/qt/3"
-libdir="$(get_libdir)"
-
pkg_setup() {
if use immqt && use immqt-bc ; then
ewarn
@@ -167,8 +165,8 @@ src_unpack() {
-e "s:\<QMAKE_LINK_SHLIB\>.*=.*:QMAKE_LINK_SHLIB=$(tc-getCXX):" \
"${S}"/mkspecs/${PLATFORM}/qmake.conf || die
- if [ ${libdir} != "lib" ] ; then
- sed -i -e "s:/lib$:/${libdir}:" \
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e "s:/lib$:/$(get_libdir):" \
"${S}"/mkspecs/${PLATFORM}/qmake.conf || die
fi
@@ -185,12 +183,12 @@ src_compile() {
addwrite "${QTBASE}/etc/settings"
addwrite "${HOME}/.qt"
- [ "${libdir}" != "lib" ] && myconf="${myconf} -L/usr/${libdir}"
+ [ "$(get_libdir)" != "lib" ] && myconf="${myconf} -L/usr/$(get_libdir)"
# unixODBC support is now a PDEPEND on dev-db/qt-unixODBC; see bug 14178.
use nas && myconf+=" -system-nas-sound"
use nis && myconf+=" -nis" || myconf+=" -no-nis"
- use mysql && myconf+=" -plugin-sql-mysql -I/usr/include/mysql -L/usr/${libdir}/mysql" || myconf+=" -no-sql-mysql"
+ use mysql && myconf+=" -plugin-sql-mysql -I/usr/include/mysql -L/usr/$(get_libdir)/mysql" || myconf+=" -no-sql-mysql"
use postgres && myconf+=" -plugin-sql-psql -I/usr/include/postgresql/server -I/usr/include/postgresql/pgsql -I/usr/include/postgresql/pgsql/server" || myconf+=" -no-sql-psql"
use firebird && myconf+=" -plugin-sql-ibase -I/opt/firebird/include" || myconf+=" -no-sql-ibase"
use sqlite && myconf+=" -plugin-sql-sqlite" || myconf+=" -no-sql-sqlite"
@@ -212,7 +210,7 @@ src_compile() {
./configure -sm -thread -stl -system-libjpeg -verbose -largefile \
-qt-imgfmt-{jpeg,mng,png} -tablet -system-libmng \
-system-libpng -xft -platform ${PLATFORM} -xplatform \
- ${PLATFORM} -xrender -prefix ${QTBASE} -libdir ${QTBASE}/${libdir} \
+ ${PLATFORM} -xrender -prefix ${QTBASE} -libdir ${QTBASE}/$(get_libdir) \
-fast -no-sql-odbc ${myconf} -dlopen-opengl || die
emake src-qmake src-moc sub-src || die
@@ -249,7 +247,7 @@ src_install() {
dolib.so lib/lib{editor,qassistantclient,designercore}.a
dolib.so lib/libqt-mt.la
dolib.so lib/libqt-mt.so.${PV/b} lib/libqui.so.1.0.0
- cd "${D}"/${QTBASE}/${libdir}
+ cd "${D}"/${QTBASE}/$(get_libdir)
for x in libqui.so ; do
ln -s $x.1.0.0 $x.1.0
@@ -287,7 +285,7 @@ src_install() {
# prl files
sed -i -e "s:${S}:${QTBASE}:g" "${S}"/lib/*.prl
- insinto ${QTBASE}/${libdir}
+ insinto ${QTBASE}/$(get_libdir)
doins "${S}"/lib/*.prl
# pkg-config file