summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-09-29 11:33:59 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-09-29 11:33:59 +0000
commitd79afe453f9a2044d6c668851fad5c64266b6c8c (patch)
treea33ecf884154e7ad72f94aa3672c1dc949b85149 /x11-libs/qt
parentpull in log4r when USE=ruby #85303 (diff)
downloadgentoo-2-d79afe453f9a2044d6c668851fad5c64266b6c8c.tar.gz
gentoo-2-d79afe453f9a2044d6c668851fad5c64266b6c8c.tar.bz2
gentoo-2-d79afe453f9a2044d6c668851fad5c64266b6c8c.zip
Add a patch which detects Sparc for Linux, from bug #134341
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'x11-libs/qt')
-rw-r--r--x11-libs/qt/ChangeLog6
-rw-r--r--x11-libs/qt/files/qt-4.1.4-sparc.patch15
-rw-r--r--x11-libs/qt/qt-4.1.4.ebuild3
3 files changed, 22 insertions, 2 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index 16b6264cee03..d53b16efad46 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.350 2006/09/22 17:42:59 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.351 2006/09/29 11:33:59 caleb Exp $
+
+ 29 Sep 2006; Caleb Tennis <caleb@gentoo.org> +files/qt-4.1.4-sparc.patch,
+ qt-4.1.4.ebuild:
+ Add a patch which detects Sparc for Linux, from bug #134341
*qt-4.0.1 (22 Sep 2006)
diff --git a/x11-libs/qt/files/qt-4.1.4-sparc.patch b/x11-libs/qt/files/qt-4.1.4-sparc.patch
new file mode 100644
index 000000000000..0f9c8059bcbf
--- /dev/null
+++ b/x11-libs/qt/files/qt-4.1.4-sparc.patch
@@ -0,0 +1,15 @@
+--- qt-x11-opensource-src-4.1.4/configure.orig 2006-09-22 15:47:43.000000000 -0600
++++ qt-x11-opensource-src-4.1.4/configure 2006-09-22 21:17:12.000000000 -0600
+@@ -1821,6 +1821,12 @@
+ fi
+ ARCH=s390
+ ;;
++ Linux:*:sparc*)
++ if [ "$OPT_VERBOSE" = "yes" ]; then
++ echo " Linux on SPARC"
++ fi
++ ARCH=sparc
++ ;;
+ *:*:*)
+ if [ "$OPT_VERBOSE" = "yes" ]; then
+ echo " Trying '$UNAME_MACHINE'..."
diff --git a/x11-libs/qt/qt-4.1.4.ebuild b/x11-libs/qt/qt-4.1.4.ebuild
index a6b8306cf2af..e719c5edd5a1 100644
--- a/x11-libs/qt/qt-4.1.4.ebuild
+++ b/x11-libs/qt/qt-4.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.1.4.ebuild,v 1.12 2006/09/14 14:07:54 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.1.4.ebuild,v 1.13 2006/09/29 11:33:59 caleb Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -101,6 +101,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/qt4-parisc-linux.diff
+ epatch ${FILESDIR}/qt-4.1.4-sparc.patch
sed -i -e 's:read acceptance:acceptance=yes:' configure