summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-08-21 02:27:53 +0000
committerAron Griffis <agriffis@gentoo.org>2003-08-21 02:27:53 +0000
commit3fad83b7dbcef6da002de71d8970e0631b967e40 (patch)
treeecec40de3c4efaac7e18ee987f6768bf51de3711 /x11-libs/rep-gtk
parentversion bump (diff)
downloadgentoo-2-3fad83b7dbcef6da002de71d8970e0631b967e40.tar.gz
gentoo-2-3fad83b7dbcef6da002de71d8970e0631b967e40.tar.bz2
gentoo-2-3fad83b7dbcef6da002de71d8970e0631b967e40.zip
version bump
Diffstat (limited to 'x11-libs/rep-gtk')
-rw-r--r--x11-libs/rep-gtk/ChangeLog8
-rw-r--r--x11-libs/rep-gtk/Manifest4
-rw-r--r--x11-libs/rep-gtk/files/digest-rep-gtk-0.181
-rw-r--r--x11-libs/rep-gtk/rep-gtk-0.18.ebuild51
4 files changed, 61 insertions, 3 deletions
diff --git a/x11-libs/rep-gtk/ChangeLog b/x11-libs/rep-gtk/ChangeLog
index 1e9d84817a2f..94498fd04d15 100644
--- a/x11-libs/rep-gtk/ChangeLog
+++ b/x11-libs/rep-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/rep-gtk
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/ChangeLog,v 1.17 2003/02/12 15:24:20 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/ChangeLog,v 1.18 2003/08/21 02:27:49 agriffis Exp $
+
+*rep-gtk-0.18 (20 Aug 2003)
+
+ 20 Aug 2003; Aron Griffis <agriffis@gentoo.org> rep-gtk-0.18.ebuild:
+ Version bump. This version includes the 64-bit patch I sent John a long time
+ ago
12 Feb 2003; Aron Griffis <agriffis@gentoo.org> files/rep-gtk-0.17-64bit.patch :
Update patch with help from John Harper
diff --git a/x11-libs/rep-gtk/Manifest b/x11-libs/rep-gtk/Manifest
index a9b571d7d38f..cd68f89220e8 100644
--- a/x11-libs/rep-gtk/Manifest
+++ b/x11-libs/rep-gtk/Manifest
@@ -1,8 +1,8 @@
-MD5 a824963ee85886d1edebb979bda369ff rep-gtk-0.18.ebuild 1220
+MD5 d2fb52d44c6ab4f87fbb981801c4b20e rep-gtk-0.18.ebuild 1219
MD5 b0e214793c93ee602ea7d5d5745a0d17 rep-gtk-0.15-r3.ebuild 1118
MD5 3cbfbe1414af72c63aaabd7501304ef0 rep-gtk-0.17.ebuild 1200
MD5 39b88923324342ac61b2a1686f0285f3 rep-gtk-0.17-r1.ebuild 1330
-MD5 c136284df8ed6cc669bef9ce43c4b0c2 ChangeLog 3026
+MD5 737e74f2c33fae43909eb4a6befadbc7 ChangeLog 3212
MD5 c5348d921904c80ce82a0a78336b1eac rep-gtk-0.16.ebuild 1453
MD5 220aadeb6d56c63c76c4a8ee31e2099f files/digest-rep-gtk-0.15-r3 64
MD5 1ea67ff5530d10194d5eb14361003264 files/digest-rep-gtk-0.17-r1 63
diff --git a/x11-libs/rep-gtk/files/digest-rep-gtk-0.18 b/x11-libs/rep-gtk/files/digest-rep-gtk-0.18
new file mode 100644
index 000000000000..db7b0f1ea4d4
--- /dev/null
+++ b/x11-libs/rep-gtk/files/digest-rep-gtk-0.18
@@ -0,0 +1 @@
+MD5 220b0d728656472c068e40823f0a3b22 rep-gtk-0.18.tar.gz 147665
diff --git a/x11-libs/rep-gtk/rep-gtk-0.18.ebuild b/x11-libs/rep-gtk/rep-gtk-0.18.ebuild
new file mode 100644
index 000000000000..da2698b9e2fd
--- /dev/null
+++ b/x11-libs/rep-gtk/rep-gtk-0.18.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-0.18.ebuild,v 1.1 2003/08/21 02:27:49 agriffis Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="A GTK+/libglade/GNOME language binding for the librep Lisp environment"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://rep-gtk.sourceforge.net/"
+SLOT="gtk-2.0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha"
+
+DEPEND="virtual/glibc
+ >=dev-util/pkgconfig-0.12.0
+ >=x11-libs/gtk+-2.0.3
+ >=gnome-base/libbonobo-2.0.0
+ >=gnome-base/libbonoboui-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0
+ >=gnome-base/libgnomecanvas-2.0.0
+ >=gnome-base/libglade-2.0.0
+ >=sys-devel/automake-1.6.1-r5
+ >=dev-libs/librep-0.13"
+
+src_compile() {
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --with-gnome \
+ --with-libglade \
+ --with-gdk-pixbuf \
+ --infodir=/usr/share/info || die
+
+ emake host_type=${CHOST} || die
+}
+
+src_install() {
+
+ make install \
+ host_type=${CHOST} \
+ installdir=${D}/usr/lib/rep/${CHOST} || die
+
+ cd ${S}
+ dodoc AUTHORS BUGS COPYING ChangeLog HACKING \
+ NEWS README* TODO
+}
+