summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-10-23 13:56:58 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-10-23 13:56:58 +0000
commit472c1bc6ab49b8223af7b14cd1ce7ef110182f60 (patch)
tree5ac808e6c49dbfba5b720c6484afba588fb6e9a1 /x11-libs/xcb-util/xcb-util-0.4.0.ebuild
parentVersion bump. (diff)
downloadgentoo-2-472c1bc6ab49b8223af7b14cd1ce7ef110182f60.tar.gz
gentoo-2-472c1bc6ab49b8223af7b14cd1ce7ef110182f60.tar.bz2
gentoo-2-472c1bc6ab49b8223af7b14cd1ce7ef110182f60.zip
Version bump. Remove old.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x2324E7B566DF2611!)
Diffstat (limited to 'x11-libs/xcb-util/xcb-util-0.4.0.ebuild')
-rw-r--r--x11-libs/xcb-util/xcb-util-0.4.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-libs/xcb-util/xcb-util-0.4.0.ebuild b/x11-libs/xcb-util/xcb-util-0.4.0.ebuild
new file mode 100644
index 000000000000..5493d8ebbcfa
--- /dev/null
+++ b/x11-libs/xcb-util/xcb-util-0.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xcb-util/xcb-util-0.4.0.ebuild,v 1.1 2014/10/23 13:56:58 chithanh Exp $
+
+EAPI=5
+
+XORG_MODULE=/
+XORG_BASE_INDIVIDUAL_URI=http://xcb.freedesktop.org/dist
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util"
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="http://xcb.freedesktop.org/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1:=[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24:=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-util/gperf-3.0.1
+ test? ( >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}] )"
+
+PDEPEND="
+ >=x11-libs/xcb-util-cursor-0.1.1:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-image-${PV}:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-keysyms-${PV}:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-renderutil-0.3.9:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-wm-${PV}:=[${MULTILIB_USEDEP}]
+"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc doxygen)
+ )
+ xorg-2_src_configure
+}