summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnant Narayanan <anant@gentoo.org>2007-03-05 14:15:58 +0000
committerAnant Narayanan <anant@gentoo.org>2007-03-05 14:15:58 +0000
commit13aaffc9c4eacc4b06b870537c1999d204be2d55 (patch)
tree78ef2c5470eedae5abaab157b3c5afd6dbd9d6e2 /x11-libs/xclass
parentFixed description in metadata. (diff)
downloadgentoo-2-13aaffc9c4eacc4b06b870537c1999d204be2d55.tar.gz
gentoo-2-13aaffc9c4eacc4b06b870537c1999d204be2d55.tar.bz2
gentoo-2-13aaffc9c4eacc4b06b870537c1999d204be2d55.zip
Fix offending header that prevented compilation; closes bug #151169
(Portage version: 2.1.2.1)
Diffstat (limited to 'x11-libs/xclass')
-rw-r--r--x11-libs/xclass/ChangeLog7
-rw-r--r--x11-libs/xclass/files/digest-xclass-0.8.2-r23
-rw-r--r--x11-libs/xclass/xclass-0.8.2-r2.ebuild63
3 files changed, 72 insertions, 1 deletions
diff --git a/x11-libs/xclass/ChangeLog b/x11-libs/xclass/ChangeLog
index a0f9d7b3852a..fc323f310335 100644
--- a/x11-libs/xclass/ChangeLog
+++ b/x11-libs/xclass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/xclass
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xclass/ChangeLog,v 1.14 2007/02/22 00:02:21 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xclass/ChangeLog,v 1.15 2007/03/05 14:15:58 anant Exp $
+
+*xclass-0.8.2-r2 (05 Mar 2007)
+
+ 05 Mar 2007; <anant@gentoo.org> +xclass-0.8.2-r2.ebuild:
+ Fix offending header that prevented compile, bump to r2; closes bug #151169
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/x11-libs/xclass/files/digest-xclass-0.8.2-r2 b/x11-libs/xclass/files/digest-xclass-0.8.2-r2
new file mode 100644
index 000000000000..f5ab705be0e9
--- /dev/null
+++ b/x11-libs/xclass/files/digest-xclass-0.8.2-r2
@@ -0,0 +1,3 @@
+MD5 34373b948e5d50a730f351a947693a75 xclass-0.8.2.tar.gz 671115
+RMD160 bc5d0053aefa1df09fa8d28a8f18f353f8d4ca38 xclass-0.8.2.tar.gz 671115
+SHA256 bec7cc2241fee81190fd6fd0d4b69f4708e2888a4ff2fe30aff0b2150462f3b3 xclass-0.8.2.tar.gz 671115
diff --git a/x11-libs/xclass/xclass-0.8.2-r2.ebuild b/x11-libs/xclass/xclass-0.8.2-r2.ebuild
new file mode 100644
index 000000000000..f115ccdca01d
--- /dev/null
+++ b/x11-libs/xclass/xclass-0.8.2-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xclass/xclass-0.8.2-r2.ebuild,v 1.1 2007/03/05 14:15:58 anant Exp $
+
+DESCRIPTION="a C++ GUI toolkit for the X windows environment"
+HOMEPAGE="http://xclass.sourceforge.net/"
+SRC_URI="ftp://mitac11.uia.ac.be/pub/xclass/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="|| ( x11-libs/libXpm virtual/x11 )
+ virtual/libc"
+DEPEND="${RDEPEND}
+ || ( x11-proto/xextproto virtual/x11 )
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i 's:example-app::' Makefile.in
+ sed -i \
+ -e 's:/usr/local/xclass-icons:/usr/share/icons/xclass:' \
+ -e 's:/usr/local/xclass:/:' \
+ lib/libxclass/Makefile.in
+ sed -i \
+ -e 's:/usr/local/xclass/icons:/usr/share/icons/xclass:' \
+ -e 's:mime\.types:xclass.mime.types:' \
+ doc/xclassrc
+ sed -i \
+ -e 's:OXListTree\:\:::' \
+ include/xclass/OXListTree.h
+}
+
+src_compile() {
+ econf --enable-shared=yes --with-x || die
+ emake || die "'emake' failed"
+}
+
+src_install() {
+ rm -rf `find . -name 'Makefile*'`
+
+ dobin config/xc-config || die "xc-config failed"
+
+ insinto /etc
+ doins doc/xclassrc || die "xclassrc failed"
+ newins doc/mime.types xclass.mime.types || die
+
+ dodoc doc/*
+
+ dodir /usr/share/icons/xclass
+ insinto /usr/share/icons/xclass
+ doins icons/*.xpm || die "icons failed"
+
+ dodir /usr/include/xclass
+ insinto /usr/include/xclass
+ doins include/xclass/*.h || die "include failed"
+
+ cd lib/libxclass
+ dolib libxclass* || die "lib failed"
+}