summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-29 00:17:49 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-29 00:17:49 +0000
commit5104a84e1d7118b806b1249c41e8355fdedb9481 (patch)
treed5c09ca368c8e018d5021834fbcfd1c290978c03 /x11-libs/xosd
parentStable ppc-macos (diff)
downloadgentoo-2-5104a84e1d7118b806b1249c41e8355fdedb9481.tar.gz
gentoo-2-5104a84e1d7118b806b1249c41e8355fdedb9481.tar.bz2
gentoo-2-5104a84e1d7118b806b1249c41e8355fdedb9481.zip
make ebuild suck less and fix m4 warnings
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'x11-libs/xosd')
-rw-r--r--x11-libs/xosd/files/xosd-2.2.14-m4.patch9
-rw-r--r--x11-libs/xosd/xosd-2.2.14.ebuild30
2 files changed, 25 insertions, 14 deletions
diff --git a/x11-libs/xosd/files/xosd-2.2.14-m4.patch b/x11-libs/xosd/files/xosd-2.2.14-m4.patch
new file mode 100644
index 000000000000..3e529728f8b3
--- /dev/null
+++ b/x11-libs/xosd/files/xosd-2.2.14-m4.patch
@@ -0,0 +1,9 @@
+Fix aclocal warning:
+/usr/share/aclocal/libxosd.m4:9: warning: underquoted definition of AM_PATH_LIBXOSD
+--- xosd-2.2.14/libxosd.m4
++++ xosd-2.2.14/libxosd.m4
+@@ -8,3 +8,3 @@
+ dnl
+-AC_DEFUN(AM_PATH_LIBXOSD,
++AC_DEFUN([AM_PATH_LIBXOSD],
+ [dnl
diff --git a/x11-libs/xosd/xosd-2.2.14.ebuild b/x11-libs/xosd/xosd-2.2.14.ebuild
index c63895217141..577cd2470a36 100644
--- a/x11-libs/xosd/xosd-2.2.14.ebuild
+++ b/x11-libs/xosd/xosd-2.2.14.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xosd/xosd-2.2.14.ebuild,v 1.1 2005/03/25 11:46:20 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xosd/xosd-2.2.14.ebuild,v 1.2 2005/04/29 00:17:49 vapier Exp $
inherit eutils
-IUSE="xinerama xmms bmp"
-
DESCRIPTION="Library for overlaying text/glyphs in X-Windows X-On-Screen-Display plus binary for sending text from command line"
HOMEPAGE="http://www.ignavus.net/"
SRC_URI="mirror://debian/pool/main/x/xosd/${PN}_${PV}.orig.tar.gz
@@ -13,33 +11,37 @@ SRC_URI="mirror://debian/pool/main/x/xosd/${PN}_${PV}.orig.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha ~hppa ~ia64 ~amd64 ~ppc64"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xinerama xmms bmp"
DEPEND="virtual/x11
- bmp? (media-sound/beep-media-player >=media-libs/gdk-pixbuf-0.22.0 )
- xmms? ( media-sound/xmms >=media-libs/gdk-pixbuf-0.22.0 )"
+ bmp? (
+ media-sound/beep-media-player
+ >=media-libs/gdk-pixbuf-0.22.0
+ )
+ xmms? (
+ media-sound/xmms
+ >=media-libs/gdk-pixbuf-0.22.0
+ )"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/2.2.8-xmms-trackpos.patch
- epatch ${DISTDIR}/${PN}_${PV}-1.diff.gz
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-m4.patch
+ epatch "${FILESDIR}"/2.2.8-xmms-trackpos.patch
+ epatch "${DISTDIR}"/${PN}_${PV}-1.diff.gz
}
src_compile() {
local myconf=""
-
use xinerama || myconf="${myconf} --disable-xinerama"
-
use xmms || myconf="${myconf} --disable-new-plugin"
use bmp || myconf="${myconf} --disable-beep_media_player"
-
-
econf ${myconf} || die
emake || die
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS COPYING README TODO
}