summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-06-27 19:22:30 +0000
committerBen de Groot <yngwin@gentoo.org>2009-06-27 19:22:30 +0000
commit09bdd7b3c7c253c889313674db0fed01fd8cbd6b (patch)
treede6d368359c39fe1d9ace76d538403853702dffd /x11-libs
parentQt 4.5.2 release version bump (diff)
downloadgentoo-2-09bdd7b3c7c253c889313674db0fed01fd8cbd6b.tar.gz
gentoo-2-09bdd7b3c7c253c889313674db0fed01fd8cbd6b.tar.bz2
gentoo-2-09bdd7b3c7c253c889313674db0fed01fd8cbd6b.zip
Qt 4.5.2 release version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-svg/ChangeLog7
-rw-r--r--x11-libs/qt-svg/qt-svg-4.5.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/x11-libs/qt-svg/ChangeLog b/x11-libs/qt-svg/ChangeLog
index c465e1d4ed42..0b12cd469823 100644
--- a/x11-libs/qt-svg/ChangeLog
+++ b/x11-libs/qt-svg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-svg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.35 2009/06/08 22:30:08 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.36 2009/06/27 19:22:30 yngwin Exp $
+
+*qt-svg-4.5.2 (27 Jun 2009)
+
+ 27 Jun 2009; Ben de Groot <yngwin@gentoo.org> +qt-svg-4.5.2.ebuild:
+ Version bump
08 Jun 2009; Jeroen Roovers <jer@gentoo.org> qt-svg-4.5.1-r1.ebuild:
Stable for HPPA (bug #266201).
diff --git a/x11-libs/qt-svg/qt-svg-4.5.2.ebuild b/x11-libs/qt-svg/qt-svg-4.5.2.ebuild
new file mode 100644
index 000000000000..081bf5c548b1
--- /dev/null
+++ b/x11-libs/qt-svg/qt-svg-4.5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.5.2.ebuild,v 1.1 2009/06/27 19:22:30 yngwin Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The SVG module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="iconv"
+
+DEPEND="~x11-libs/qt-gui-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/svg
+src/plugins/imageformats/svg
+src/plugins/iconengines/svgiconengine"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/QtSvg/
+include/Qt/
+include/QtGui/
+include/QtCore/
+include/QtXml/
+src/corelib/
+src/gui/
+src/plugins/
+src/xml
+src/3rdparty"
+
+QCONFIG_ADD="svg"
+QCONFIG_DEFINE="QT_SVG"
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -svg -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -v -no-fontconfig -no-glib -no-opengl -no-gtkstyle -continue"
+ qt4-build_src_configure
+}