summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-03-04 21:07:23 +0000
committerBen de Groot <yngwin@gentoo.org>2009-03-04 21:07:23 +0000
commit0a709ec635c3025be8046771cec3d83a5f43a4de (patch)
tree8161e3893c1433a08d0a566ffcee5984783bdaf0 /x11-libs
parentBump KDE 4.2.1 (diff)
downloadgentoo-2-0a709ec635c3025be8046771cec3d83a5f43a4de.tar.gz
gentoo-2-0a709ec635c3025be8046771cec3d83a5f43a4de.tar.bz2
gentoo-2-0a709ec635c3025be8046771cec3d83a5f43a4de.zip
Qt 4.5.0 release version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-assistant/ChangeLog7
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.5.0.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index 96e47c525632..dadb90a29181 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.27 2009/02/18 20:16:38 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.28 2009/03/04 21:07:23 yngwin Exp $
+
+*qt-assistant-4.5.0 (04 Mar 2009)
+
+ 04 Mar 2009; Ben de Groot <yngwin@gentoo.org> +qt-assistant-4.5.0.ebuild:
+ Version bump
18 Feb 2009; Jeroen Roovers <jer@gentoo.org> qt-assistant-4.4.2-r1.ebuild:
Stable for HPPA (bug #248083).
diff --git a/x11-libs/qt-assistant/qt-assistant-4.5.0.ebuild b/x11-libs/qt-assistant/qt-assistant-4.5.0.ebuild
new file mode 100644
index 000000000000..c0acdd945b92
--- /dev/null
+++ b/x11-libs/qt-assistant/qt-assistant-4.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.5.0.ebuild,v 1.1 2009/03/04 21:07:23 yngwin Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The assistant help module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 -sparc ~x86"
+IUSE=""
+
+DEPEND="~x11-libs/qt-gui-${PV}[debug=]
+ ~x11-libs/qt-sql-${PV}[debug=,sqlite]
+ ~x11-libs/qt-webkit-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+# Pixeltool isn't really assistant related, but it relies on
+# the assistant libraries. And qdoc3 is needed by qt-creator...
+QT4_TARGET_DIRECTORIES="tools/assistant tools/pixeltool tools/qdoc3"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+src/3rdparty/clucene/
+tools/shared/fontpanel
+include/
+src/
+doc/"
+
+src_configure() {
+ myconf="${myconf} -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-qt3support -no-svg -no-gtkstyle"
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+ insinto ${QTDOCDIR}
+ doins -r "${S}"/doc/qch/ || die "Installing qch documentation failed"
+ dobin "${S}"/tools/qdoc3/qdoc3 || die "Installing qdoc3 failed"
+ domenu "${FILESDIR}"/Assistant.desktop
+}