summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-01-26 13:17:41 +0000
committerPacho Ramos <pacho@gentoo.org>2015-01-26 13:17:41 +0000
commit17a79b620faf34980ef217eab4fdaec3d22bd7e0 (patch)
tree3cab4d3c5bc3454ffb1d10c331d215beb0d05ede /x11-libs
parentRemove old. (diff)
downloadgentoo-2-17a79b620faf34980ef217eab4fdaec3d22bd7e0.tar.gz
gentoo-2-17a79b620faf34980ef217eab4fdaec3d22bd7e0.tar.bz2
gentoo-2-17a79b620faf34980ef217eab4fdaec3d22bd7e0.zip
Version bump, drop old
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/vte/ChangeLog10
-rw-r--r--x11-libs/vte/vte-0.38.3.ebuild (renamed from x11-libs/vte/vte-0.36.2.ebuild)34
2 files changed, 28 insertions, 16 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 01b6d734d8da..dd294dd369aa 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/vte
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.399 2014/12/15 23:30:21 eva Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.400 2015/01/26 13:17:41 pacho Exp $
+
+*vte-0.38.3 (26 Jan 2015)
+
+ 26 Jan 2015; Pacho Ramos <pacho@gentoo.org> +vte-0.38.3.ebuild,
+ -vte-0.36.2.ebuild:
+ Version bump, drop old
15 Dec 2014; Gilles Dartiguelongue <eva@gentoo.org> vte-0.38.2.ebuild:
Fix bad edit, DEPEND -> RDEPEND.
diff --git a/x11-libs/vte/vte-0.36.2.ebuild b/x11-libs/vte/vte-0.38.3.ebuild
index 2aac58cbbd8a..08a9631e482c 100644
--- a/x11-libs/vte/vte-0.36.2.ebuild
+++ b/x11-libs/vte/vte-0.38.3.ebuild
@@ -1,24 +1,25 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.36.2.ebuild,v 1.1 2014/05/31 09:14:12 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.38.3.ebuild,v 1.1 2015/01/26 13:17:41 pacho Exp $
EAPI="5"
-GCONF_DEBUG="yes"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
-inherit eutils gnome2
+inherit eutils gnome2 vala
DESCRIPTION="Library providing a virtual terminal emulator widget"
HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE"
LICENSE="LGPL-2+"
-SLOT="2.90"
-IUSE="debug glade +introspection"
+SLOT="2.91"
+IUSE="debug glade +introspection vala"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
-PDEPEND="=x11-libs/gnome-pty-helper-${PV}"
+PDEPEND=">=x11-libs/gnome-pty-helper-${PV}"
RDEPEND="
- >=dev-libs/glib-2.31.13:2
- >=x11-libs/gtk+-3.1.9:3[introspection?]
+ >=dev-libs/glib-2.40:2
+ >=x11-libs/gtk+-3.8:3[introspection?]
>=x11-libs/pango-1.22.0
sys-libs/ncurses
@@ -29,16 +30,18 @@ RDEPEND="
introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
"
DEPEND="${RDEPEND}
+ $(vala_depend)
>=dev-util/gtk-doc-am-1.13
>=dev-util/intltool-0.35
sys-devel/gettext
virtual/pkgconfig
"
+RDEPEND="${RDEPEND}
+ !x11-libs/vte:2.90[glade]
+"
src_prepare() {
- # https://bugzilla.gnome.org/show_bug.cgi?id=663779
- epatch "${FILESDIR}/${PN}-0.30.1-alt-meta.patch"
-
+ vala_src_prepare
gnome2_src_prepare
}
@@ -57,14 +60,17 @@ src_configure() {
# Do not disable gnome-pty-helper, bug #401389
gnome2_src_configure \
--disable-deprecation \
+ --disable-test-application \
--disable-static \
$(use_enable debug) \
$(use_enable glade glade-catalogue) \
- $(use_enable introspection)
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ ${myconf}
}
src_install() {
DOCS="AUTHORS ChangeLog HACKING NEWS README"
gnome2_src_install
- rm -v "${ED}usr/libexec/gnome-pty-helper" || die
+ mv "${D}"/etc/profile.d/vte{,-${SLOT}}.sh || die
}