summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-10-10 05:38:00 +0000
committerUlrich Müller <ulm@gentoo.org>2010-10-10 05:38:00 +0000
commit467bbf3285c2eddfeac9121476547935677f7883 (patch)
tree7f5e8f571edab684417d8c3c2c6d8dc0cccac334 /x11-libs
parentVersion bump (diff)
downloadgentoo-2-467bbf3285c2eddfeac9121476547935677f7883.tar.gz
gentoo-2-467bbf3285c2eddfeac9121476547935677f7883.tar.bz2
gentoo-2-467bbf3285c2eddfeac9121476547935677f7883.zip
Move x11-libs/openmotif-compat-2.2.3-r1 to openmotif-2.2.3-r10 in SLOT 2.2.
(Portage version: 2.1.9.14/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/openmotif/ChangeLog7
-rw-r--r--x11-libs/openmotif/openmotif-2.2.3-r10.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/x11-libs/openmotif/ChangeLog b/x11-libs/openmotif/ChangeLog
index 0530b7a953f8..0d84e0ba39d6 100644
--- a/x11-libs/openmotif/ChangeLog
+++ b/x11-libs/openmotif/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/openmotif
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.246 2010/10/06 15:16:32 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.247 2010/10/10 05:38:00 ulm Exp $
+
+*openmotif-2.2.3-r10 (10 Oct 2010)
+
+ 10 Oct 2010; Ulrich Mueller <ulm@gentoo.org> +openmotif-2.2.3-r10.ebuild:
+ Move x11-libs/openmotif-compat-2.2.3-r1 to openmotif-2.2.3-r10 in SLOT 2.2.
06 Oct 2010; Jeroen Roovers <jer@gentoo.org> openmotif-2.3.3.ebuild:
Stable for HPPA (bug #338208).
diff --git a/x11-libs/openmotif/openmotif-2.2.3-r10.ebuild b/x11-libs/openmotif/openmotif-2.2.3-r10.ebuild
new file mode 100644
index 000000000000..daf4e1ddad9b
--- /dev/null
+++ b/x11-libs/openmotif/openmotif-2.2.3-r10.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.2.3-r10.ebuild,v 1.1 2010/10/10 05:38:00 ulm Exp $
+
+WANT_AUTOMAKE="1.6"
+
+inherit eutils flag-o-matic multilib autotools
+
+MY_P=openMotif-${PV}
+DESCRIPTION="Legacy Open Motif libraries for old binaries"
+HOMEPAGE="http://www.motifzone.net/"
+SRC_URI="ftp://ftp.ics.com/openmotif/2.2/${PV}/src/${MY_P}.tar.gz
+ mirror://gentoo/${P}-patches-4.tar.bz2"
+
+LICENSE="MOTIF MIT"
+SLOT="2.2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!x11-libs/motif-config
+ !x11-libs/lesstif
+ x11-libs/libXmu
+ x11-libs/libXp"
+
+DEPEND="${RDEPEND}
+ x11-libs/libXaw
+ x11-misc/xbitmaps"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ EPATCH_SUFFIX=patch epatch
+
+ # This replaces deprecated, obsoleted and now invalid AC_DEFINE
+ # with their proper alternatives.
+ sed -i -e 's:AC_DEFINE(\([^)]*\)):AC_DEFINE(\1, [], [\1]):g' \
+ configure.in acinclude.m4
+
+ # Build only the libraries
+ sed -i -e '/^SUBDIRS/{:x;/\\$/{N;bx;};s/=.*/= lib clients/;}' Makefile.am
+ sed -i -e '/^SUBDIRS/{:x;/\\$/{N;bx;};s/=.*/= uil/;}' clients/Makefile.am
+
+ eautoreconf
+}
+
+src_compile() {
+ # get around some LANG problems in make (#15119)
+ unset LANG
+
+ # bug #80421
+ filter-flags -ftracer
+
+ # multilib includes don't work right in this package...
+ has_multilib_profile && append-flags "-I$(get_ml_incdir)"
+
+ # feel free to fix properly if you care
+ append-flags -fno-strict-aliasing
+
+ econf --with-x || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install-exec || die "emake install failed"
+
+ # cleanups
+ rm -Rf "${D}"/usr/bin
+ rm -f "${D}"/usr/$(get_libdir)/*.{so,la,a}
+
+ dodoc README RELEASE RELNOTES BUGREPORT TODO
+}