summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 22:16:43 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 22:16:43 +0000
commit4b10e91bdf6e1d1ab1fb757d63fd3e3b863629d5 (patch)
tree89302515a3685f480cbb7e7531e5a4d2cf48800e /x11-libs
parentVersion bump, bug 460186 (diff)
downloadgentoo-2-4b10e91bdf6e1d1ab1fb757d63fd3e3b863629d5.tar.gz
gentoo-2-4b10e91bdf6e1d1ab1fb757d63fd3e3b863629d5.tar.bz2
gentoo-2-4b10e91bdf6e1d1ab1fb757d63fd3e3b863629d5.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libcryptui/ChangeLog10
-rw-r--r--x11-libs/libcryptui/libcryptui-3.8.0.ebuild64
2 files changed, 71 insertions, 3 deletions
diff --git a/x11-libs/libcryptui/ChangeLog b/x11-libs/libcryptui/ChangeLog
index 6b4889af5366..fa13d73ad184 100644
--- a/x11-libs/libcryptui/ChangeLog
+++ b/x11-libs/libcryptui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libcryptui
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libcryptui/ChangeLog,v 1.5 2012/12/23 17:28:27 eva Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libcryptui/ChangeLog,v 1.6 2013/03/28 22:16:43 pacho Exp $
+
+*libcryptui-3.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +libcryptui-3.8.0.ebuild:
+ Version bump for Gnome 3.8
*libcryptui-3.6.0 (23 Dec 2012)
@@ -33,4 +38,3 @@
+libcryptui-3.2.0.ebuild, +metadata.xml:
New ebuild from the gnome overlay. Contains the widget library that was split
off from app-crypt/seahorse in gnome-3.1.x.
-
diff --git a/x11-libs/libcryptui/libcryptui-3.8.0.ebuild b/x11-libs/libcryptui/libcryptui-3.8.0.ebuild
new file mode 100644
index 000000000000..3b36ce2d03fb
--- /dev/null
+++ b/x11-libs/libcryptui/libcryptui-3.8.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libcryptui/libcryptui-3.8.0.ebuild,v 1.1 2013/03/28 22:16:43 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="User interface components for OpenPGP"
+HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1"
+SLOT="0"
+IUSE="+introspection libnotify test"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+# Pull in libnotify-0.7 because it's controlled via an automagic ifdef
+COMMON_DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3:3[introspection?]
+ >=dev-libs/dbus-glib-0.72
+ >=gnome-base/gnome-keyring-2.91.2
+ x11-libs/libICE
+ x11-libs/libSM
+
+ >=app-crypt/gpgme-1
+ || (
+ =app-crypt/gnupg-2.0*
+ =app-crypt/gnupg-1.4* )
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4 )
+ libnotify? ( >=x11-libs/libnotify-0.7.0 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=app-text/scrollkeeper-0.3
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# Before 3.1.4, libcryptui was part of seahorse
+RDEPEND="${COMMON_DEPEND}
+ !<app-crypt/seahorse-3.1.4
+"
+
+src_prepare() {
+ # FIXME: Do not mess with CFLAGS with USE="debug"
+ sed -e '/CFLAGS="$CFLAGS -g -O0/d' \
+ -e 's/-Werror//' \
+ -i configure.ac configure || die "sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-update-mime-database
+ $(use_enable introspection)
+ $(use_enable libnotify)
+ $(use_enable test tests)"
+ gnome2_src_configure
+}