summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2005-03-07 19:46:42 +0000
committerHeinrich Wendel <lanius@gentoo.org>2005-03-07 19:46:42 +0000
commit65ffa55305cb81e2fa36215a6e981a83a9f0b706 (patch)
tree7f8da8406738f06fedc4df55eb96e91dec378614 /x11-libs
parentUse virtual/baselayout now. (diff)
downloadgentoo-2-65ffa55305cb81e2fa36215a6e981a83a9f0b706.tar.gz
gentoo-2-65ffa55305cb81e2fa36215a6e981a83a9f0b706.tar.bz2
gentoo-2-65ffa55305cb81e2fa36215a6e981a83a9f0b706.zip
make motif-config usable on ppc-macos
(Portage version: 2.0.51.19)
Diffstat (limited to 'x11-libs')
-rwxr-xr-xx11-libs/motif-config/files/motif-config-0.413
-rw-r--r--x11-libs/motif-config/motif-config-0.4.ebuild4
2 files changed, 11 insertions, 6 deletions
diff --git a/x11-libs/motif-config/files/motif-config-0.4 b/x11-libs/motif-config/files/motif-config-0.4
index bf13afe95e70..4533c678b9dc 100755
--- a/x11-libs/motif-config/files/motif-config-0.4
+++ b/x11-libs/motif-config/files/motif-config-0.4
@@ -4,10 +4,6 @@
# based on gcc-config by Martin Schlemmer <azarah@gentoo.org
# Author: Heinrich Wendel <lanius@gentoo.org>
-source /etc/init.d/functions.sh || {
- echo "$0: Could not source /etc/init.d/functions.sh!"
- exit 1
-}
umask 022
PROFILE_PATH=/usr/@@LIBDIR@@/motif
@@ -48,6 +44,15 @@ USAGE_END
[[ $# -lt 1 ]] && usage 1
[[ $# -gt 2 ]] && usage 1
+# redefine eerror/einfo to remove baselayout dep
+# to make ppc-macos people happy
+eerror() {
+ echo -e " \e[31;01m*\e[0m $*";
+}
+einfo() {
+ echo -e " \e[32;01m*\e[0m $*";
+}
+
_check_root() {
if [[ "$(id -u)" -ne 0 ]] ; then
eerror "$0: Must be root."
diff --git a/x11-libs/motif-config/motif-config-0.4.ebuild b/x11-libs/motif-config/motif-config-0.4.ebuild
index 8a1807b30f15..78e73e75c366 100644
--- a/x11-libs/motif-config/motif-config-0.4.ebuild
+++ b/x11-libs/motif-config/motif-config-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/motif-config/motif-config-0.4.ebuild,v 1.1 2005/03/07 13:38:08 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/motif-config/motif-config-0.4.ebuild,v 1.2 2005/03/07 19:46:42 lanius Exp $
inherit multilib
@@ -10,7 +10,7 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -ppc-macos ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~sparc ~x86"
IUSE=""
DEPEND=""