summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-12 02:21:18 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-12 02:21:18 +0000
commit81328fdf8636db272e5f7389774779d8fe645658 (patch)
tree8a8afbc1655a60cbf3fc4f7b986f2dce94ce9272 /x11-libs
parentFix regression from 0.1.2 and include GLIBC 2.10+ patch again wrt #281117. (diff)
downloadgentoo-2-81328fdf8636db272e5f7389774779d8fe645658.tar.gz
gentoo-2-81328fdf8636db272e5f7389774779d8fe645658.tar.bz2
gentoo-2-81328fdf8636db272e5f7389774779d8fe645658.zip
Version bump (bug #267437).
(Portage version: 14007-svn/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pixman/ChangeLog8
-rw-r--r--x11-libs/pixman/pixman-0.15.20.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/x11-libs/pixman/ChangeLog b/x11-libs/pixman/ChangeLog
index 43ce0d03d234..ad55a0a3dc50 100644
--- a/x11-libs/pixman/ChangeLog
+++ b/x11-libs/pixman/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/pixman
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/ChangeLog,v 1.42 2009/05/15 14:37:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/ChangeLog,v 1.43 2009/08/12 02:21:18 arfrever Exp $
+
+*pixman-0.15.20 (12 Aug 2009)
+
+ 12 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pixman-0.15.20.ebuild:
+ Version bump (bug #267437).
15 May 2009; Raúl Porcel <armin76@gentoo.org> pixman-0.14.0-r1.ebuild:
arm/s390 stable
diff --git a/x11-libs/pixman/pixman-0.15.20.ebuild b/x11-libs/pixman/pixman-0.15.20.ebuild
new file mode 100644
index 000000000000..bedad1423a96
--- /dev/null
+++ b/x11-libs/pixman/pixman-0.15.20.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/pixman-0.15.20.ebuild,v 1.1 2009/08/12 02:21:18 arfrever Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular toolchain-funcs versionator
+
+DESCRIPTION="Low-level pixel manipulation routines"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="altivec mmx sse2"
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="
+ $(use_enable altivec vmx)
+ --disable-gtk"
+
+ local enable_mmx="$(use mmx && echo 1 || echo 0)"
+ local enable_sse2="$(use sse2 && echo 1 || echo 0)"
+
+ # this block fixes bug #260287
+ if use x86; then
+ if use sse2 && ! $(version_is_at_least "4.2" "$(gcc-version)"); then
+ ewarn "SSE2 instructions require GCC 4.2 or higher."
+ ewarn "pixman will be built *without* SSE2 support"
+ enable_sse2="0"
+ fi
+ fi
+
+ # this block fixes bug #236558
+ case "$enable_mmx,$enable_sse2" in
+ '1,1')
+ CONFIGURE_OPTIONS="${CONFIGURE_OPTIONS} --enable-mmx --enable-sse2" ;;
+ '1,0')
+ CONFIGURE_OPTIONS="${CONFIGURE_OPTIONS} --enable-mmx --disable-sse2" ;;
+ '0,1')
+ ewarn "You enabled SSE2 but have MMX disabled. This is an invalid."
+ ewarn "pixman will be built *without* MMX/SSE2 support."
+ CONFIGURE_OPTIONS="${CONFIGURE_OPTIONS} --disable-mmx --disable-sse2" ;;
+ '0,0')
+ CONFIGURE_OPTIONS="${CONFIGURE_OPTIONS} --disable-mmx --disable-sse2" ;;
+ esac
+}
+
+src_unpack() {
+ x-modular_src_unpack
+ cd "${S}"
+
+ epatch "${FILESDIR}"/pixman-0.12.0-sse.patch
+
+ eautoreconf
+ elibtoolize
+}