summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-07-02 21:47:31 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-07-02 21:47:31 +0000
commit8885ad2a0d7bede16ab9b7b5cc9cc8ee4bdea04b (patch)
treed9bdb08f6a3b0bca38ec2e6afe8f7d9b5bba2f53 /x11-libs
parentWorkaround portage IUSE deficiencies by adding the expanded crosscompile_opts. (diff)
downloadgentoo-2-8885ad2a0d7bede16ab9b7b5cc9cc8ee4bdea04b.tar.gz
gentoo-2-8885ad2a0d7bede16ab9b7b5cc9cc8ee4bdea04b.tar.bz2
gentoo-2-8885ad2a0d7bede16ab9b7b5cc9cc8ee4bdea04b.zip
bump to 1.20.5. fix a crasher bug with Linux-Libertine font.
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/ChangeLog7
-rw-r--r--x11-libs/pango/pango-1.20.5.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index c587490dff70..eb68fc2443cd 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/pango
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.220 2008/06/30 16:15:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.221 2008/07/02 21:47:31 eva Exp $
+
+*pango-1.20.5 (02 Jul 2008)
+
+ 02 Jul 2008; Gilles Dartiguelongue <eva@gentoo.org> +pango-1.20.5.ebuild:
+ bump to 1.20.5. fix a crasher bug with Linux-Libertine font.
30 Jun 2008; Jeroen Roovers <jer@gentoo.org> pango-1.20.3.ebuild:
Stable for HPPA (bug #227679).
diff --git a/x11-libs/pango/pango-1.20.5.ebuild b/x11-libs/pango/pango-1.20.5.ebuild
new file mode 100644
index 000000000000..bca4f558ac73
--- /dev/null
+++ b/x11-libs/pango/pango-1.20.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.20.5.ebuild,v 1.1 2008/07/02 21:47:31 eva Exp $
+
+inherit eutils gnome2 multilib
+
+DESCRIPTION="Text rendering and layout library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2 FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="X doc"
+
+# glib-2.16.3 dependency instead of 2.14 ensures Unicode 5.1 support on the system
+RDEPEND=">=dev-libs/glib-2.16.3
+ >=media-libs/fontconfig-1.0.1
+ >=media-libs/freetype-2
+ >=x11-libs/cairo-1.2.6
+ X? (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXft
+ )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ X? ( x11-proto/xproto )
+ doc? (
+ >=dev-util/gtk-doc-1
+ ~app-text/docbook-xml-dtd-4.1.2
+ )"
+
+DOCS="AUTHORS ChangeLog* NEWS README"
+
+function multilib_enabled() {
+ has_multilib_profile || ( use x86 && [ "$(get_libdir)" == "lib32" ] )
+}
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_with X x)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # make config file location host specific so that a 32bit and 64bit pango
+ # wont fight with each other on a multilib system. Fix building for
+ # emul-linux-x86-gtklibs
+ if multilib_enabled ; then
+ epatch "${FILESDIR}/${PN}-1.2.5-lib64.patch"
+ fi
+
+ epunt_cxx
+}
+
+src_install() {
+ gnome2_src_install
+ rm "${D}/etc/pango/pango.modules"
+}
+
+pkg_postinst() {
+ if [[ "${ROOT}" == "/" ]] ; then
+ einfo "Generating modules listing..."
+
+ local PANGO_CONFDIR=
+
+ if multilib_enabled ; then
+ PANGO_CONFDIR="/etc/pango/${CHOST}"
+ else
+ PANGO_CONFDIR="/etc/pango"
+ fi
+
+ mkdir -p ${PANGO_CONFDIR}
+
+ pango-querymodules > ${PANGO_CONFDIR}/pango.modules
+ fi
+}