summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-06-10 14:43:22 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-06-10 14:43:22 +0000
commit930452ea1dc946de55eddadd07f7ebe414f440d6 (patch)
treea4110de70350db4b01e9a3583a03d8336c4535b6 /x11-libs
parentevo 1.4 and deps (diff)
downloadgentoo-2-930452ea1dc946de55eddadd07f7ebe414f440d6.tar.gz
gentoo-2-930452ea1dc946de55eddadd07f7ebe414f440d6.tar.bz2
gentoo-2-930452ea1dc946de55eddadd07f7ebe414f440d6.zip
Version bump. Fixes bug #21618
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/fox/ChangeLog7
-rw-r--r--x11-libs/fox/Manifest2
-rw-r--r--x11-libs/fox/files/digest-fox-1.0.401
-rw-r--r--x11-libs/fox/fox-1.0.40.ebuild51
4 files changed, 60 insertions, 1 deletions
diff --git a/x11-libs/fox/ChangeLog b/x11-libs/fox/ChangeLog
index 20181a2c5b9c..510f785ed9f8 100644
--- a/x11-libs/fox/ChangeLog
+++ b/x11-libs/fox/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for x11-libs/fox
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.6 2003/02/12 09:22:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.7 2003/06/10 14:43:22 rphillips Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+*fox-1.0.40 (10 Jun 2003)
+
+ 10 Jun 2003; Ryan Phillips <rphillips@gentoo.org> :
+ Version bump. Fixes bug #21618
+
*fox-1.0.29 (26 Dec 2002)
26 Dec 2002; Ryan Phillips <rphillips@gentoo.org> :
diff --git a/x11-libs/fox/Manifest b/x11-libs/fox/Manifest
index f176ff518521..302e1e144987 100644
--- a/x11-libs/fox/Manifest
+++ b/x11-libs/fox/Manifest
@@ -2,6 +2,8 @@ MD5 9938e4d8e61d4279b660bbb555de6aa0 ChangeLog 676
MD5 63c975725a69f68a1702eb5a2c996d6f fox-1.0.17.ebuild 1194
MD5 331fab22f1d88053fd1ce10967efa23e fox-1.0.26.ebuild 1196
MD5 e6a3b93fafb188a3974bf32c872e2793 fox-1.0.29.ebuild 1196
+MD5 e6a3b93fafb188a3974bf32c872e2793 fox-1.0.40.ebuild 1196
MD5 1bfc6e9a2a4bd1fd14b3d5fea96cdea5 files/digest-fox-1.0.17 63
MD5 ac90c4d744ac7dcf07c7ac22b82a4baf files/digest-fox-1.0.26 63
+MD5 e66ac5665267aa76e1efc8da12cc8928 files/digest-fox-1.0.40 63
MD5 1f1094d046a00ed88e391cb30b6b4dfc files/digest-fox-1.0.29 64
diff --git a/x11-libs/fox/files/digest-fox-1.0.40 b/x11-libs/fox/files/digest-fox-1.0.40
new file mode 100644
index 000000000000..62168bda41aa
--- /dev/null
+++ b/x11-libs/fox/files/digest-fox-1.0.40
@@ -0,0 +1 @@
+MD5 ada6b371c5a876239c7416496884c24a fox-1.0.40.tar.gz 2132412
diff --git a/x11-libs/fox/fox-1.0.40.ebuild b/x11-libs/fox/fox-1.0.40.ebuild
new file mode 100644
index 000000000000..7d89109d146f
--- /dev/null
+++ b/x11-libs/fox/fox-1.0.40.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.0.40.ebuild,v 1.1 2003/06/10 14:43:22 rphillips Exp $
+
+IUSE="cups opengl"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="C++ based Toolkit for developing Graphical User Interfaces easily a nd effectively"
+
+SRC_URI="http://www.fox-toolkit.org/ftp/${P}.tar.gz"
+
+HOMEPAGE="http://www.fox-toolkit.org"
+
+SLOT="0"
+KEYWORDS="x86 ~sparc "
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ opengl? ( virtual/opengl )"
+
+
+src_compile() {
+
+ local myconf
+
+ use opengl || myconf="$myconf --with-opengl=no" #default enabled
+ use cups && myconf="$myconf --enable-cups" #default disabled
+
+ ./configure \
+ --prefix=/usr \
+ --mandir='${prefix}'/share/man \
+ --host=${CHOST} \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+src_install () {
+
+ make prefix=${D}/usr/ \
+ install || die "Installation Failed"
+
+ dodoc README INSTALL LICENSE ADDITIONS AUTHORS TRACING
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/fox/html/* ${D}/usr/share/doc/${PF}/html/
+ rmdir ${D}/usr/fox/html
+ rmdir ${D}/usr/fox
+}