summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-12-22 23:35:13 +0000
committerMarinus Schraal <foser@gentoo.org>2002-12-22 23:35:13 +0000
commit94cba0bf05a2ff3ae0b00660d2e58339f46f3bae (patch)
treecfb7280a01dedfb77e9e31a7167112a521527eab /x11-libs
parentdigest-spectromatic-1.0 (diff)
downloadgentoo-2-94cba0bf05a2ff3ae0b00660d2e58339f46f3bae.tar.gz
gentoo-2-94cba0bf05a2ff3ae0b00660d2e58339f46f3bae.tar.bz2
gentoo-2-94cba0bf05a2ff3ae0b00660d2e58339f46f3bae.zip
New version
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/ChangeLog7
-rw-r--r--x11-libs/pango/files/digest-pango-1.2.01
-rw-r--r--x11-libs/pango/pango-1.2.0.ebuild58
3 files changed, 65 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index 8d6c3e8c9a05..0afe8940434a 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/pango
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.25 2002/12/15 02:14:03 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.26 2002/12/22 23:35:13 foser Exp $
+
+*pango-1.2.0.ebuild (22 Dec 2002)
+
+ 22 Dec 2002; foser <foser@gentoo.org> pango-1.2.0.ebuild :
+ New stable version
14 Dec 2002; Aron Griffis <agriffis@gentoo.org> pango-1.1.3.ebuild :
REALLY commented out the slighthinting patch, for the same reason as Bart
diff --git a/x11-libs/pango/files/digest-pango-1.2.0 b/x11-libs/pango/files/digest-pango-1.2.0
new file mode 100644
index 000000000000..e9bb51786b85
--- /dev/null
+++ b/x11-libs/pango/files/digest-pango-1.2.0
@@ -0,0 +1 @@
+MD5 7e84cce50628021c596202a186d66024 pango-1.2.0.tar.bz2 788709
diff --git a/x11-libs/pango/pango-1.2.0.ebuild b/x11-libs/pango/pango-1.2.0.ebuild
new file mode 100644
index 000000000000..6d4a523cbdff
--- /dev/null
+++ b/x11-libs/pango/pango-1.2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.2.0.ebuild,v 1.1 2002/12/22 23:35:13 foser Exp $
+
+inherit eutils libtool
+
+IUSE="doc"
+SLOT="1"
+KEYWORDS="~x86 ~ppc"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Text rendering and Layout library"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.2/${P}.tar.bz2"
+HOMEPAGE="http://www.pango.org/"
+LICENSE="LGPL-2.1"
+
+RDEPEND="virtual/x11
+ virtual/xft
+ >=dev-libs/glib-2.1.3
+ >=media-libs/fontconfig-2
+ >=media-libs/freetype-2.0.1"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9
+ app-text/sgmltools-lite )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Some enhancements from Redhat
+ epatch ${FILESDIR}/pango-1.0.99.020606-xfonts.patch
+ #epatch ${FILESDIR}/pango-1.1.0-slighthint.patch
+}
+
+src_compile() {
+ elibtoolize
+ local myconf=""
+ use doc && myconf="--enable-gtk-doc" || myconf="--disable-gtk-doc"
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug"
+ fi
+
+ econf ${myconf} --without-qt || die
+ make || die "serial make failed"
+}
+
+src_install() {
+ einstall
+ rm ${D}/etc/pango/pango.modules
+
+ dodoc AUTHORS ChangeLog COPYING README INSTALL NEWS TODO*
+}
+
+pkg_postinst() {
+ pango-querymodules >/etc/pango/pango.modules
+}