summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-05-15 18:30:37 +0000
committerPacho Ramos <pacho@gentoo.org>2013-05-15 18:30:37 +0000
commita27ff8ba04e46b301106cc46d58ab750fc01c43a (patch)
tree4e3b01a278245c4e5a76adb516243ead3a6af4b0 /x11-libs
parentFix LICENSE, proprietary license according to AVM. Redistribution is not allo... (diff)
downloadgentoo-2-a27ff8ba04e46b301106cc46d58ab750fc01c43a.tar.gz
gentoo-2-a27ff8ba04e46b301106cc46d58ab750fc01c43a.tar.bz2
gentoo-2-a27ff8ba04e46b301106cc46d58ab750fc01c43a.zip
Version bump
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/ChangeLog7
-rw-r--r--x11-libs/pango/pango-1.34.1.ebuild90
2 files changed, 96 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index ddadf3c289ba..d43f73bacdd2 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/pango
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.372 2013/04/30 14:04:19 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.373 2013/05/15 18:30:37 pacho Exp $
+
+*pango-1.34.1 (15 May 2013)
+
+ 15 May 2013; Pacho Ramos <pacho@gentoo.org> +pango-1.34.1.ebuild:
+ Version bump
30 Apr 2013; Alexandre Rostovtsev <tetromino@gentoo.org> pango-1.30.1.ebuild,
pango-1.32.5.ebuild, +files/pango-1.30.1-AM_CONFIG_HEADER.patch,
diff --git a/x11-libs/pango/pango-1.34.1.ebuild b/x11-libs/pango/pango-1.34.1.ebuild
new file mode 100644
index 000000000000..d74472f5b3b0
--- /dev/null
+++ b/x11-libs/pango/pango-1.34.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.34.1.ebuild,v 1.1 2013/05/15 18:30:37 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 multilib toolchain-funcs
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2+ FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="X +introspection"
+
+# Bump cairo dep to be safer:
+# https://bugzilla.gnome.org/show_bug.cgi?id=700247#c4
+RDEPEND="
+ >=media-libs/harfbuzz-0.9.9:=
+ >=dev-libs/glib-2.33.12:2
+ >=media-libs/fontconfig-2.10.91:1.0=
+ media-libs/freetype:2=
+ >=x11-libs/cairo-1.12.10:=[X?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ X? (
+ x11-libs/libXrender
+ x11-libs/libX11
+ >=x11-libs/libXft-2.0.0 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.13
+ virtual/pkgconfig
+ X? ( x11-proto/xproto )
+ !<=sys-devel/autoconf-2.63:2.5
+"
+
+src_prepare() {
+ tc-export CXX
+
+ epatch "${FILESDIR}/${PN}-1.32.1-lib64.patch"
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_with X xft) \
+ "$(usex X --x-includes="${EPREFIX}/usr/include" "")" \
+ "$(usex X --x-libraries="${EPREFIX}/usr/$(get_libdir)" "")"
+}
+
+src_install() {
+ gnome2_src_install
+
+ local PANGO_CONFDIR="/etc/pango/${CHOST}"
+ dodir "${PANGO_CONFDIR}"
+ keepdir "${PANGO_CONFDIR}"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ einfo "Generating modules listing..."
+ local PANGO_CONFDIR="${EROOT}/etc/pango/${CHOST}"
+ local pango_conf="${PANGO_CONFDIR}/pango.modules"
+ local tmp_file=$(mktemp -t tmp_pango_ebuild.XXXXXXXXXX)
+
+ # be atomic!
+ if pango-querymodules --system \
+ "${EROOT}"usr/$(get_libdir)/pango/1.8.0/modules/*$(get_modname) \
+ > "${tmp_file}"; then
+ cat "${tmp_file}" > "${pango_conf}" || {
+ rm "${tmp_file}"; die; }
+ else
+ ewarn "Cannot update pango.modules, file generation failed"
+ fi
+ rm "${tmp_file}"
+
+ if [[ ${REPLACING_VERSIONS} < 1.30.1 ]]; then
+ elog "In >=${PN}-1.30.1, default configuration file locations moved from"
+ elog "~/.pangorc and ~/.pangox_aliases to ~/.config/pango/pangorc and"
+ elog "~/.config/pango/pangox.aliases"
+ fi
+}