summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-01-05 05:06:28 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-01-05 05:06:28 +0000
commitb26091a0c2b16ef218dda1e92618fcb4b5e65d2e (patch)
tree0a9b19b8a0893d4ccba52b0cc73dd6edd7e691ad /x11-libs
parentAnd now that the whole tree is fixed, this should return on global scope to b... (diff)
downloadgentoo-2-b26091a0c2b16ef218dda1e92618fcb4b5e65d2e.tar.gz
gentoo-2-b26091a0c2b16ef218dda1e92618fcb4b5e65d2e.tar.bz2
gentoo-2-b26091a0c2b16ef218dda1e92618fcb4b5e65d2e.zip
fix debug codepaths
(Portage version: 2.1.2_rc4-r5)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/cairo/ChangeLog5
-rw-r--r--x11-libs/cairo/cairo-1.2.6.ebuild7
-rw-r--r--x11-libs/cairo/cairo-1.3.10.ebuild8
3 files changed, 12 insertions, 8 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index fefb91c77ec5..94a69731dd2a 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/cairo
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.96 2007/01/05 04:48:44 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.97 2007/01/05 05:06:28 compnerd Exp $
+
+ 05 Jan 2007; Saleem Abdulrasool <compnerd@gentoo.org> ChangeLog:
+ Fixing debug paths
05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> cairo-1.2.6.ebuild,
cairo-1.3.10.ebuild:
diff --git a/x11-libs/cairo/cairo-1.2.6.ebuild b/x11-libs/cairo/cairo-1.2.6.ebuild
index fc53b6c13047..7c20ccb2d05b 100644
--- a/x11-libs/cairo/cairo-1.2.6.ebuild
+++ b/x11-libs/cairo/cairo-1.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.2.6.ebuild,v 1.5 2007/01/05 04:48:44 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.2.6.ebuild,v 1.6 2007/01/05 05:06:28 compnerd Exp $
inherit eutils flag-o-matic
@@ -42,8 +42,9 @@ src_compile() {
append-flags -finline-limit=1200
econf $(use_enable X xlib) $(use_enable doc gtk-doc) $(use_enable directfb) \
- $(use_enable debug) $(use_enable svg) --enable-pdf \
- $(use_enable glitz) --enable-png --enable-freetype --enable-ps \
+ $(use_enable svg) $(use_enable glitz) $(use_enable debug gcov) \
+ $(use_enable debug test-surfaces) --enable-pdf --enable-png \
+ --enable-freetype --enable-ps \
|| die "configure failed"
emake || die "compile failed"
diff --git a/x11-libs/cairo/cairo-1.3.10.ebuild b/x11-libs/cairo/cairo-1.3.10.ebuild
index fa61e3e439d8..1cb07c06dd5b 100644
--- a/x11-libs/cairo/cairo-1.3.10.ebuild
+++ b/x11-libs/cairo/cairo-1.3.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.3.10.ebuild,v 1.4 2007/01/05 04:48:44 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.3.10.ebuild,v 1.5 2007/01/05 05:06:28 compnerd Exp $
inherit eutils flag-o-matic libtool
@@ -53,9 +53,9 @@ src_compile() {
append-flags -finline-limit=1200
econf $(use_enable X xlib) $(use_enable doc gtk-doc) $(use_enable directfb) \
- $(use_enable debug) $(use_enable svg) --enable-pdf \
- $(use_enable glitz) --enable-png --enable-freetype --enable-ps \
- $(use_enable xcb) \
+ $(use_enable svg) $(use_enable glitz) $(use_enable debug gcov) \
+ $(use_enable debug test-surfaces) --enable-pdf --enable-png \
+ --enable-freetype --enable-ps $(use_enable xcb) \
|| die "configure failed"
emake || die "compile failed"