summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-12-07 16:05:35 +0000
committerAlex Alexander <wired@gentoo.org>2010-12-07 16:05:35 +0000
commitb4105b6f3c574c5003764c7194c68d1e60c6e36a (patch)
treecf32de66a71cb0ecbeefb2c49807685972e4742d /x11-libs
parentadd -jit as default in hardened profile (diff)
downloadgentoo-2-b4105b6f3c574c5003764c7194c68d1e60c6e36a.tar.gz
gentoo-2-b4105b6f3c574c5003764c7194c68d1e60c6e36a.tar.bz2
gentoo-2-b4105b6f3c574c5003764c7194c68d1e60c6e36a.zip
added missing [debug=] to all qt-* deps, bug #345925
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-assistant/ChangeLog7
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.6.2-r2.ebuild8
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.6.3.ebuild8
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild10
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.7.1.ebuild10
5 files changed, 24 insertions, 19 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index a1c39a5a8daa..3d5109b5f029 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.100 2010/12/05 21:45:26 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.101 2010/12/07 16:05:35 wired Exp $
+
+ 07 Dec 2010; Alex Alexander <wired@gentoo.org> qt-assistant-4.6.2-r2.ebuild,
+ qt-assistant-4.6.3.ebuild, qt-assistant-4.7.0.ebuild,
+ qt-assistant-4.7.1.ebuild:
+ added missing [debug=] to all qt-* deps, bug #345925
05 Dec 2010; Alex Alexander <wired@gentoo.org> -qt-assistant-4.5.3.ebuild:
removed 4.5.3
diff --git a/x11-libs/qt-assistant/qt-assistant-4.6.2-r2.ebuild b/x11-libs/qt-assistant/qt-assistant-4.6.2-r2.ebuild
index e91bb2467e51..26117ab94815 100644
--- a/x11-libs/qt-assistant/qt-assistant-4.6.2-r2.ebuild
+++ b/x11-libs/qt-assistant/qt-assistant-4.6.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.6.2-r2.ebuild,v 1.3 2010/11/05 18:05:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.6.2-r2.ebuild,v 1.4 2010/12/07 16:05:35 wired Exp $
EAPI="2"
inherit qt4-build
@@ -10,9 +10,9 @@ SLOT="4"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE="trace"
-DEPEND="~x11-libs/qt-gui-${PV}[aqua=,trace?]
- ~x11-libs/qt-sql-${PV}[aqua=,sqlite]
- ~x11-libs/qt-webkit-${PV}[aqua=]"
+DEPEND="~x11-libs/qt-gui-${PV}[aqua=,debug=,trace?]
+ ~x11-libs/qt-sql-${PV}[aqua=,debug=,sqlite]
+ ~x11-libs/qt-webkit-${PV}[aqua=,debug=]"
RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}/${PN}-4.6.1-tools.patch" )
diff --git a/x11-libs/qt-assistant/qt-assistant-4.6.3.ebuild b/x11-libs/qt-assistant/qt-assistant-4.6.3.ebuild
index ac40c6c4dc4d..898100bd7684 100644
--- a/x11-libs/qt-assistant/qt-assistant-4.6.3.ebuild
+++ b/x11-libs/qt-assistant/qt-assistant-4.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.6.3.ebuild,v 1.8 2010/11/05 18:05:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.6.3.ebuild,v 1.9 2010/12/07 16:05:35 wired Exp $
EAPI="2"
inherit qt4-build
@@ -10,9 +10,9 @@ SLOT="4"
KEYWORDS="alpha amd64 arm ia64 ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE="trace"
-DEPEND="~x11-libs/qt-gui-${PV}[aqua=,trace?]
- ~x11-libs/qt-sql-${PV}[aqua=,sqlite]
- ~x11-libs/qt-webkit-${PV}[aqua=]"
+DEPEND="~x11-libs/qt-gui-${PV}[aqua=,debug=,trace?]
+ ~x11-libs/qt-sql-${PV}[aqua=,debug=,sqlite]
+ ~x11-libs/qt-webkit-${PV}[aqua=,debug=]"
RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}/${P}-tools.patch" )
diff --git a/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild b/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
index 5bc5057cff2c..2f5f62ca1cb4 100644
--- a/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
+++ b/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild,v 1.8 2010/11/09 09:12:02 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild,v 1.9 2010/12/07 16:05:35 wired Exp $
EAPI="3"
inherit qt4-build
@@ -11,10 +11,10 @@ KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
IUSE="compat doc +glib qt3support trace"
SRC_URI+=" compat? ( ftp://ftp.qt.nokia.com/qt/source/${PN}-qassistantclient-library-compat-src-4.6.3.tar.gz )"
-DEPEND="~x11-libs/qt-gui-${PV}[aqua=,glib=,qt3support=,trace?]
- ~x11-libs/qt-sql-${PV}[aqua=,qt3support=,sqlite]
- ~x11-libs/qt-webkit-${PV}[aqua=]
- ~x11-libs/qt-declarative-${PV}[qt3support=]"
+DEPEND="~x11-libs/qt-gui-${PV}[aqua=,debug=,glib=,qt3support=,trace?]
+ ~x11-libs/qt-sql-${PV}[aqua=,debug=,qt3support=,sqlite]
+ ~x11-libs/qt-webkit-${PV}[aqua=,debug=]
+ ~x11-libs/qt-declarative-${PV}[debug=,qt3support=]"
RDEPEND="${DEPEND}"
pkg_setup() {
diff --git a/x11-libs/qt-assistant/qt-assistant-4.7.1.ebuild b/x11-libs/qt-assistant/qt-assistant-4.7.1.ebuild
index b217a49e0ac6..2c0be438e9e2 100644
--- a/x11-libs/qt-assistant/qt-assistant-4.7.1.ebuild
+++ b/x11-libs/qt-assistant/qt-assistant-4.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.7.1.ebuild,v 1.1 2010/11/09 15:51:17 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.7.1.ebuild,v 1.2 2010/12/07 16:05:35 wired Exp $
EAPI="3"
inherit qt4-build
@@ -11,10 +11,10 @@ KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
IUSE="compat doc +glib qt3support trace"
SRC_URI+=" compat? ( ftp://ftp.qt.nokia.com/qt/source/${PN}-qassistantclient-library-compat-src-4.6.3.tar.gz )"
-DEPEND="~x11-libs/qt-gui-${PV}[aqua=,glib=,qt3support=,trace?]
- ~x11-libs/qt-sql-${PV}[aqua=,qt3support=,sqlite]
- ~x11-libs/qt-webkit-${PV}[aqua=]
- ~x11-libs/qt-declarative-${PV}[qt3support=]"
+DEPEND="~x11-libs/qt-gui-${PV}[aqua=,debug=,glib=,qt3support=,trace?]
+ ~x11-libs/qt-sql-${PV}[aqua=,debug=,qt3support=,sqlite]
+ ~x11-libs/qt-webkit-${PV}[aqua=,debug=]
+ ~x11-libs/qt-declarative-${PV}[debug=,qt3support=]"
RDEPEND="${DEPEND}"
pkg_setup() {