summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-08-11 05:38:38 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-08-11 05:38:38 +0000
commitc61c7fb0991aacedaa3efdadebfa50f69109b499 (patch)
tree339d7f01ee53a7ecb41fbc8d52d8b536b6466bde /x11-libs
parentDrop unneeded patch. (diff)
downloadgentoo-2-c61c7fb0991aacedaa3efdadebfa50f69109b499.tar.gz
gentoo-2-c61c7fb0991aacedaa3efdadebfa50f69109b499.tar.bz2
gentoo-2-c61c7fb0991aacedaa3efdadebfa50f69109b499.zip
Version bump.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/glamor/ChangeLog9
-rw-r--r--x11-libs/glamor/files/glamor-0.4.1-xorg-server-1.13.patch269
-rw-r--r--x11-libs/glamor/glamor-0.4.1-r1.ebuild39
-rw-r--r--x11-libs/glamor/glamor-0.5.ebuild (renamed from x11-libs/glamor/glamor-0.4.1.ebuild)8
4 files changed, 11 insertions, 314 deletions
diff --git a/x11-libs/glamor/ChangeLog b/x11-libs/glamor/ChangeLog
index 445a01bcd2e2..b7e9395efdb3 100644
--- a/x11-libs/glamor/ChangeLog
+++ b/x11-libs/glamor/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/glamor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/ChangeLog,v 1.5 2012/08/08 13:50:48 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/ChangeLog,v 1.6 2012/08/11 05:38:37 chithanh Exp $
+
+*glamor-0.5 (11 Aug 2012)
+
+ 11 Aug 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +glamor-0.5.ebuild, -files/glamor-0.4.1-xorg-server-1.13.patch,
+ -glamor-0.4.1-r1.ebuild, -glamor-0.4.1.ebuild:
+ Version bump.
*glamor-0.4.1-r1 (08 Aug 2012)
diff --git a/x11-libs/glamor/files/glamor-0.4.1-xorg-server-1.13.patch b/x11-libs/glamor/files/glamor-0.4.1-xorg-server-1.13.patch
deleted file mode 100644
index 4e16ad584694..000000000000
--- a/x11-libs/glamor/files/glamor-0.4.1-xorg-server-1.13.patch
+++ /dev/null
@@ -1,269 +0,0 @@
-From 726ad264f485ce1d39aa387e93ac224fb46ed059 Mon Sep 17 00:00:00 2001
-From: Zhigang Gong <zhigang.gong@linux.intel.com>
-Date: Mon, 16 Jul 2012 03:25:09 +0000
-Subject: Synch with xorg 1.13 change.
-
-As xorg 1.13 change the scrn interaces and remove those
-global arrays. Some API change cause we can't build. Now
-fix it.
-
-Signed-off-by: Zhigang Gong <zhigang.gong@linux.intel.com>
----
-diff --git a/src/glamor.c b/src/glamor.c
-index 8b7dc93..d51811e 100644
---- a/src/glamor.c
-+++ b/src/glamor.c
-@@ -491,7 +491,7 @@ glamor_set_pixmap_private(PixmapPtr pixmap, glamor_pixmap_private *priv)
- }
-
- Bool
--glamor_close_screen(int idx, ScreenPtr screen)
-+glamor_close_screen(CLOSE_SCREEN_ARGS_DECL)
- {
- glamor_screen_private *glamor_priv;
- PixmapPtr screen_pixmap;
-@@ -533,7 +533,7 @@ glamor_close_screen(int idx, ScreenPtr screen)
-
- glamor_release_screen_priv(screen);
-
-- return screen->CloseScreen(idx, screen);
-+ return screen->CloseScreen(CLOSE_SCREEN_ARGS);
- }
-
-
-diff --git a/src/glamor.h b/src/glamor.h
-index fe3e4f8..bafd543 100644
---- a/src/glamor.h
-+++ b/src/glamor.h
-@@ -30,9 +30,8 @@
- #define GLAMOR_H
-
- #include <scrnintstr.h>
--#ifdef GLAMOR_FOR_XORG
-+#include <xf86.h>
- #include <xf86str.h>
--#endif
- #include <pixmapstr.h>
- #include <gcstruct.h>
- #include <picturestr.h>
-@@ -117,7 +116,11 @@ extern _X_EXPORT void glamor_fini(ScreenPtr screen);
- * screen pixmap which must be a glamor pixmap and requires
- * the internal data structure still exist at that time.
- * Otherwise, the glamor internal structure will not be freed.*/
--extern _X_EXPORT Bool glamor_close_screen(int idx, ScreenPtr screen);
-+#ifndef XF86_SCRN_INTERFACE
-+extern _X_EXPORT Bool glamor_close_screen(int scrnIndex, ScreenPtr screen);
-+#else
-+extern _X_EXPORT Bool glamor_close_screen(ScreenPtr screen);
-+#endif
-
-
- /* Let glamor to know the screen's fbo. The low level
-diff --git a/src/glamor_egl.c b/src/glamor_egl.c
-index 07acf1a..da9283b 100644
---- a/src/glamor_egl.c
-+++ b/src/glamor_egl.c
-@@ -59,6 +59,7 @@
- #include <EGL/eglext.h>
-
- #include "glamor.h"
-+#include "compat-api.h"
- #include "glamor_gl_dispatch.h"
- #ifdef GLX_USE_SHARED_DISPATCH
- #include "glapi.h"
-@@ -365,7 +366,7 @@ glamor_egl_destroy_textured_pixmap(PixmapPtr pixmap)
- }
-
- static Bool
--glamor_egl_close_screen(int idx, ScreenPtr screen)
-+glamor_egl_close_screen(CLOSE_SCREEN_ARGS_DECL)
- {
- ScrnInfoPtr scrn;
- struct glamor_egl_screen_private *glamor_egl;
-@@ -391,7 +392,7 @@ glamor_egl_close_screen(int idx, ScreenPtr screen)
-
- screen->CloseScreen = glamor_egl->saved_close_screen;
-
-- return screen->CloseScreen(idx, screen);
-+ return screen->CloseScreen(CLOSE_SCREEN_ARGS);
- }
-
- static Bool
-@@ -430,10 +431,15 @@ glamor_egl_screen_init(ScreenPtr screen)
- }
-
- static void
--glamor_egl_free_screen(int scrnIndex, int flags)
-+glamor_egl_free_screen(FREE_SCREEN_ARGS_DECL)
- {
-- ScrnInfoPtr scrn = xf86Screens[scrnIndex];
-+ ScrnInfoPtr scrn;
- struct glamor_egl_screen_private *glamor_egl;
-+#ifndef XF86_SCRN_INTERFACE
-+ scrn = xf86Screens[arg];
-+#else
-+ scrn = arg;
-+#endif
-
- glamor_egl = glamor_egl_get_screen_private(scrn);
- if (glamor_egl != NULL) {
-@@ -447,7 +453,7 @@ glamor_egl_free_screen(int scrnIndex, int flags)
- #endif
- scrn->FreeScreen = glamor_egl->saved_free_screen;
- free(glamor_egl);
-- scrn->FreeScreen(scrnIndex, flags);
-+ scrn->FreeScreen(FREE_SCREEN_ARGS);
- }
- }
-
-diff --git a/src/glamor_priv.h b/src/glamor_priv.h
-index 3b64c31..11d09c4 100644
---- a/src/glamor_priv.h
-+++ b/src/glamor_priv.h
-@@ -38,6 +38,7 @@
- #define NDEBUG
- #endif
- #include "glamor.h"
-+#include "compat-api.h"
-
- #define GL_GLEXT_PROTOTYPES
-
-diff --git a/src/glamor_utils.h b/src/glamor_utils.h
-index a282985..eb2e202 100644
---- a/src/glamor_utils.h
-+++ b/src/glamor_utils.h
-@@ -798,7 +798,10 @@ region_is_empty(pixman_region16_t *region)
- return region->data && region->data->numRects == 0;
- }
-
-+#ifndef ARRAY_SIZE
- #define ARRAY_SIZE(x) (sizeof(x) / sizeof(x[0]))
-+#endif
-+
- #define ALIGN(i,m) (((i) + (m) - 1) & ~((m) - 1))
- #define MIN(a,b) ((a) < (b) ? (a) : (b))
- #define MAX(a,b) ((a) > (b) ? (a) : (b))
---
-cgit v0.9.0.2-2-gbebe
-From ab212d3b90cd288da46af43390feacb489db77b1 Mon Sep 17 00:00:00 2001
-From: Zhigang Gong <zhigang.gong@linux.intel.com>
-Date: Mon, 16 Jul 2012 09:27:22 +0000
-Subject: Added the missed header file for xorg 1.13 compat.
-
-Signed-off-by: Zhigang Gong <zhigang.gong@linux.intel.com>
----
-diff --git a/src/compat-api.h b/src/compat-api.h
-new file mode 100644
-index 0000000..1608478
---- a/dev/null
-+++ b/src/compat-api.h
-@@ -0,0 +1,107 @@
-+/*
-+ * Copyright 2012 Red Hat, Inc.
-+ *
-+ * Permission is hereby granted, free of charge, to any person obtaining a
-+ * copy of this software and associated documentation files (the "Software"),
-+ * to deal in the Software without restriction, including without limitation
-+ * the rights to use, copy, modify, merge, publish, distribute, sublicense,
-+ * and/or sell copies of the Software, and to permit persons to whom the
-+ * Software is furnished to do so, subject to the following conditions:
-+ *
-+ * The above copyright notice and this permission notice (including the next
-+ * paragraph) shall be included in all copies or substantial portions of the
-+ * Software.
-+ *
-+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-+ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
-+ * THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-+ * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
-+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
-+ * DEALINGS IN THE SOFTWARE.
-+ *
-+ * Author: Dave Airlie <airlied@redhat.com>
-+ */
-+
-+/* this file provides API compat between server post 1.13 and pre it,
-+ it should be reused inside as many drivers as possible */
-+#ifndef COMPAT_API_H
-+#define COMPAT_API_H
-+
-+#ifndef GLYPH_HAS_GLYPH_PICTURE_ACCESSOR
-+#define GetGlyphPicture(g, s) GlyphPicture((g))[(s)->myNum]
-+#define SetGlyphPicture(g, s, p) GlyphPicture((g))[(s)->myNum] = p
-+#endif
-+
-+#ifndef XF86_HAS_SCRN_CONV
-+#define xf86ScreenToScrn(s) xf86Screens[(s)->myNum]
-+#define xf86ScrnToScreen(s) screenInfo.screens[(s)->scrnIndex]
-+#endif
-+
-+#ifndef XF86_SCRN_INTERFACE
-+
-+#define SCRN_ARG_TYPE int
-+#define SCRN_INFO_PTR(arg1) ScrnInfoPtr scrn = xf86Screens[(arg1)]
-+
-+#define SCREEN_ARG_TYPE int
-+#define SCREEN_PTR(arg1) ScreenPtr screen = screenInfo.screens[(arg1)]
-+
-+#define SCREEN_INIT_ARGS_DECL int scrnIndex, ScreenPtr screen, int argc, char **argv
-+
-+#define BLOCKHANDLER_ARGS_DECL int arg, pointer blockData, pointer timeout, pointer read_mask
-+#define BLOCKHANDLER_ARGS arg, blockData, timeout, read_mask
-+
-+#define WAKEUPHANDLER_ARGS_DECL int arg, pointer wakeupData, unsigned long result, pointer read_mask
-+#define WAKEUPHANDLER_ARGS arg, wakeupData, result, read_mask
-+
-+#define CLOSE_SCREEN_ARGS_DECL int scrnIndex, ScreenPtr screen
-+#define CLOSE_SCREEN_ARGS scrnIndex, screen
-+
-+#define ADJUST_FRAME_ARGS_DECL int arg, int x, int y, int flags
-+#define ADJUST_FRAME_ARGS(arg, x, y) (arg)->scrnIndex, x, y, 0
-+
-+#define SWITCH_MODE_ARGS_DECL int arg, DisplayModePtr mode, int flags
-+#define SWITCH_MODE_ARGS(arg, m) (arg)->scrnIndex, m, 0
-+
-+#define FREE_SCREEN_ARGS_DECL int arg, int flags
-+#define FREE_SCREEN_ARGS arg, flags
-+
-+#define VT_FUNC_ARGS_DECL int arg, int flags
-+#define VT_FUNC_ARGS(flags) scrn->scrnIndex, (flags)
-+
-+#define XF86_ENABLEDISABLEFB_ARG(x) ((x)->scrnIndex)
-+
-+#else
-+#define SCRN_ARG_TYPE ScrnInfoPtr
-+#define SCRN_INFO_PTR(arg1) ScrnInfoPtr scrn = (arg1)
-+
-+#define SCREEN_ARG_TYPE ScreenPtr
-+#define SCREEN_PTR(arg1) ScreenPtr screen = (arg1)
-+
-+#define SCREEN_INIT_ARGS_DECL ScreenPtr screen, int argc, char **argv
-+
-+#define BLOCKHANDLER_ARGS_DECL ScreenPtr arg, pointer timeout, pointer read_mask
-+#define BLOCKHANDLER_ARGS arg, timeout, read_mask
-+
-+#define WAKEUPHANDLER_ARGS_DECL ScreenPtr arg, unsigned long result, pointer read_mask
-+#define WAKEUPHANDLER_ARGS arg, result, read_mask
-+
-+#define CLOSE_SCREEN_ARGS_DECL ScreenPtr screen
-+#define CLOSE_SCREEN_ARGS screen
-+
-+#define ADJUST_FRAME_ARGS_DECL ScrnInfoPtr arg, int x, int y
-+#define ADJUST_FRAME_ARGS(arg, x, y) arg, x, y
-+
-+#define SWITCH_MODE_ARGS_DECL ScrnInfoPtr arg, DisplayModePtr mode
-+#define SWITCH_MODE_ARGS(arg, m) arg, m
-+
-+#define FREE_SCREEN_ARGS_DECL ScrnInfoPtr arg
-+#define FREE_SCREEN_ARGS arg
-+
-+#define VT_FUNC_ARGS_DECL ScrnInfoPtr arg
-+#define VT_FUNC_ARGS(flags) scrn
-+
-+#define XF86_ENABLEDISABLEFB_ARG(x) (x)
-+
-+#endif
-+#endif
---
-cgit v0.9.0.2-2-gbebe
diff --git a/x11-libs/glamor/glamor-0.4.1-r1.ebuild b/x11-libs/glamor/glamor-0.4.1-r1.ebuild
deleted file mode 100644
index bf95cf5e1de6..000000000000
--- a/x11-libs/glamor/glamor-0.4.1-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/glamor-0.4.1-r1.ebuild,v 1.1 2012/08/08 13:50:48 chithanh Exp $
-
-EAPI=4
-
-XORG_DRI=always
-XORG_EAUTORECONF=yes
-inherit xorg-2
-
-DESCRIPTION="OpenGL based 2D rendering acceleration library"
-SRC_URI="mirror://gentoo/glamor-0.4.1.tar.gz"
-
-KEYWORDS="~amd64 ~ia64 ~x86"
-IUSE="gles"
-
-RDEPEND=">=x11-base/xorg-server-1.10
- media-libs/mesa[egl,gbm]
- gles? (
- || ( media-libs/mesa[gles2] media-libs/mesa[gles] )
- )
- >=x11-libs/pixman-0.21.8"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-xorg-server-1.13.patch
-)
-
-pkg_setup() {
- xorg-2_pkg_setup
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable gles glamor-gles2)
- )
-}
-
-src_prepare() {
- sed -i 's/inst_LTLIBRARIES/lib_LTLIBRARIES/' src/Makefile.am || die
- xorg-2_src_prepare
-}
diff --git a/x11-libs/glamor/glamor-0.4.1.ebuild b/x11-libs/glamor/glamor-0.5.ebuild
index 3fcdc4f081a2..05da4c2256e3 100644
--- a/x11-libs/glamor/glamor-0.4.1.ebuild
+++ b/x11-libs/glamor/glamor-0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/glamor-0.4.1.ebuild,v 1.4 2012/07/31 12:14:31 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/glamor-0.5.ebuild,v 1.1 2012/08/11 05:38:37 chithanh Exp $
EAPI=4
@@ -9,20 +9,18 @@ XORG_EAUTORECONF=yes
inherit xorg-2
DESCRIPTION="OpenGL based 2D rendering acceleration library"
-SRC_URI="mirror://gentoo/glamor-0.4.1.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
KEYWORDS="~amd64 ~ia64 ~x86"
IUSE="gles"
RDEPEND=">=x11-base/xorg-server-1.10
- <x11-base/xorg-server-1.12.99
media-libs/mesa[egl,gbm]
gles? (
|| ( media-libs/mesa[gles2] media-libs/mesa[gles] )
)
>=x11-libs/pixman-0.21.8"
-DEPEND="${RDEPEND}
-"
+DEPEND="${RDEPEND}"
pkg_setup() {
xorg-2_pkg_setup