summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-06-29 09:05:54 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-06-29 09:05:54 +0000
commitd70cdccbf9aea796a33f8724a3c9aa0e40041f4e (patch)
tree6d6a69438ea236e73520d28ddf15a053993f85e8 /x11-libs
parentVersion bump. Install FindEigen3.cmake as some packages started to use it sin... (diff)
downloadgentoo-2-d70cdccbf9aea796a33f8724a3c9aa0e40041f4e.tar.gz
gentoo-2-d70cdccbf9aea796a33f8724a3c9aa0e40041f4e.tar.bz2
gentoo-2-d70cdccbf9aea796a33f8724a3c9aa0e40041f4e.zip
version bump
Signed-off-by: Alexis Ballier <aballier@gentoo.org> (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libQGLViewer/ChangeLog7
-rw-r--r--x11-libs/libQGLViewer/libQGLViewer-2.6.3.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/x11-libs/libQGLViewer/ChangeLog b/x11-libs/libQGLViewer/ChangeLog
index 2ee289328fe8..15c26bab68fb 100644
--- a/x11-libs/libQGLViewer/ChangeLog
+++ b/x11-libs/libQGLViewer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libQGLViewer
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libQGLViewer/ChangeLog,v 1.10 2015/06/22 07:58:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libQGLViewer/ChangeLog,v 1.11 2015/06/29 09:05:54 aballier Exp $
+
+*libQGLViewer-2.6.3 (29 Jun 2015)
+
+ 29 Jun 2015; Alexis Ballier <aballier@gentoo.org> +libQGLViewer-2.6.3.ebuild:
+ version bump
*libQGLViewer-2.6.2 (22 Jun 2015)
diff --git a/x11-libs/libQGLViewer/libQGLViewer-2.6.3.ebuild b/x11-libs/libQGLViewer/libQGLViewer-2.6.3.ebuild
new file mode 100644
index 000000000000..e954d62b1828
--- /dev/null
+++ b/x11-libs/libQGLViewer/libQGLViewer-2.6.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libQGLViewer/libQGLViewer-2.6.3.ebuild,v 1.1 2015/06/29 09:05:54 aballier Exp $
+
+EAPI="5"
+
+inherit qt4-r2 multilib flag-o-matic
+
+DESCRIPTION="C++ library based on Qt that eases the creation of OpenGL 3D viewers"
+HOMEPAGE="http://www.libqglviewer.com"
+SRC_URI="http://www.libqglviewer.com/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="designer examples"
+
+DEPEND="virtual/opengl
+ virtual/glu
+ dev-qt/qtopengl:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}
+ designer? ( dev-qt/designer:4 )"
+
+src_configure() {
+ append-ldflags "-L${S}/QGLViewer"
+ sed -e 's#designerPlugin##' -i ${P}.pro || die
+ use examples || sed -e 's#examples examples/contribs##' -i ${P}.pro || die
+ eqmake4 ${P}.pro \
+ PREFIX="${EPREFIX}/usr" \
+ LIB_DIR="${EPREFIX}/usr/$(get_libdir)" \
+ DOC_DIR="${EPREFIX}/usr/share/doc/${PF}/html"
+ if use designer ; then
+ cd "${S}/designerPlugin"
+ eqmake4 designerPlugin.pro
+ fi
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ dodoc README
+
+ if use designer ; then
+ cd "${S}/designerPlugin"
+ emake INSTALL_ROOT="${D}" install
+ fi
+
+ if use examples ; then
+ exeinto /usr/bin/${PN}-examples
+ doexe $(find "${S}/examples" -type f -executable ! -name '*.vcproj')
+ fi
+}