summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-03-01 19:10:08 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-03-01 19:10:08 +0000
commitdf049ecf0f6966c3bb46b8a04ce7bf8fe87e114b (patch)
treea349163deae12d9e44874cb642068fe053723b94 /x11-libs
parentVersion bump Qt 4.7.2 (diff)
downloadgentoo-2-df049ecf0f6966c3bb46b8a04ce7bf8fe87e114b.tar.gz
gentoo-2-df049ecf0f6966c3bb46b8a04ce7bf8fe87e114b.tar.bz2
gentoo-2-df049ecf0f6966c3bb46b8a04ce7bf8fe87e114b.zip
Version bump Qt 4.7.2
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-script/ChangeLog10
-rw-r--r--x11-libs/qt-script/qt-script-4.7.2.ebuild46
2 files changed, 54 insertions, 2 deletions
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index f0845f16a907..b476a28f07a7 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-script
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.86 2010/12/23 07:56:36 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.87 2011/03/01 19:10:08 tampakrap Exp $
+
+*qt-script-4.7.2 (01 Mar 2011)
+
+ 01 Mar 2011; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-script-4.7.2.ebuild:
+ Version bump Qt 4.7.2
23 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> qt-script-4.6.3.ebuild:
ppc64 stable wrt #341703
diff --git a/x11-libs/qt-script/qt-script-4.7.2.ebuild b/x11-libs/qt-script/qt-script-4.7.2.ebuild
new file mode 100644
index 000000000000..9625bfc53e56
--- /dev/null
+++ b/x11-libs/qt-script/qt-script-4.7.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/qt-script-4.7.2.ebuild,v 1.1 2011/03/01 19:10:08 tampakrap Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The ECMAScript module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="iconv +jit private-headers"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="src/script/"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/Qt/
+ include/QtCore/
+ include/QtScript/
+ src/3rdparty/javascriptcore/
+ src/corelib/"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) $(qt_use jit javascript-jit) -no-xkb
+ -no-fontconfig -no-xrender -no-xrandr -no-xfixes -no-xcursor -no-xinerama
+ -no-xshape -no-sm -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif
+ -no-libpng -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-accessibility -no-fontconfig -no-glib -no-opengl -no-svg
+ -no-gtkstyle"
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+ #install private headers
+ if use private-headers; then
+ insinto "${QTHEADERDIR#${EPREFIX}}"/QtScript/private
+ find "${S}"/src/script -type f -name "*_p.h" -exec doins {} \;
+ fi
+}