summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-05-30 11:49:19 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-05-30 11:49:19 +0000
commiteaaa67bc664240564c91f19efaf5a1d745e0a9f5 (patch)
tree7227c8f210bcfac30d75e6c169847b055f0ac8dc /x11-libs
parentalpha/ia64 stable wrt #171107 (diff)
downloadgentoo-2-eaaa67bc664240564c91f19efaf5a1d745e0a9f5.tar.gz
gentoo-2-eaaa67bc664240564c91f19efaf5a1d745e0a9f5.tar.bz2
gentoo-2-eaaa67bc664240564c91f19efaf5a1d745e0a9f5.zip
Add firebird include dir
(Portage version: 2.1.2.4)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/ChangeLog5
-rw-r--r--x11-libs/qt/qt-3.3.8-r2.ebuild4
-rw-r--r--x11-libs/qt/qt-4.3.0_rc1.ebuild4
3 files changed, 8 insertions, 5 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index cabc1df804d7..7680d3dd47f2 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/qt
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.443 2007/05/17 11:48:46 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.444 2007/05/30 11:49:19 caleb Exp $
+
+ 30 May 2007; Caleb Tennis <caleb@gentoo.org> qt-3.3.8-r2.ebuild:
+ Add firebird include dir
17 May 2007; Caleb Tennis <caleb@gentoo.org> qt-4.3.0_rc1.ebuild:
explicitly disable pch here, from bug #178843
diff --git a/x11-libs/qt/qt-3.3.8-r2.ebuild b/x11-libs/qt/qt-3.3.8-r2.ebuild
index 89492da4865a..049f03c49925 100644
--- a/x11-libs/qt/qt-3.3.8-r2.ebuild
+++ b/x11-libs/qt/qt-3.3.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.3.8-r2.ebuild,v 1.9 2007/04/28 16:56:36 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.3.8-r2.ebuild,v 1.10 2007/05/30 11:49:19 caleb Exp $
# *** Please remember to update qt3.eclass when revbumping this ***
@@ -177,7 +177,7 @@ src_compile() {
use gif && myconf="${myconf} -qt-gif" || myconf="${myconf} -no-gif"
use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/$(get_libdir)/mysql" || myconf="${myconf} -no-sql-mysql"
use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql/server -I/usr/include/postgresql/pgsql -I/usr/include/postgresql/pgsql/server" || myconf="${myconf} -no-sql-psql"
- use firebird && myconf="${myconf} -plugin-sql-ibase" || myconf="${myconf} -no-sql-ibase"
+ use firebird && myconf="${myconf} -plugin-sql-ibase -I/opt/firebird/include" || myconf="${myconf} -no-sql-ibase"
use sqlite && myconf="${myconf} -plugin-sql-sqlite" || myconf="${myconf} -no-sql-sqlite"
use cups && myconf="${myconf} -cups" || myconf="${myconf} -no-cups"
use opengl && myconf="${myconf} -enable-module=opengl" || myconf="${myconf} -disable-opengl"
diff --git a/x11-libs/qt/qt-4.3.0_rc1.ebuild b/x11-libs/qt/qt-4.3.0_rc1.ebuild
index 88c4d7940bf6..3b3aff4101b4 100644
--- a/x11-libs/qt/qt-4.3.0_rc1.ebuild
+++ b/x11-libs/qt/qt-4.3.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.3.0_rc1.ebuild,v 1.4 2007/05/17 11:48:46 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.3.0_rc1.ebuild,v 1.5 2007/05/30 11:49:19 caleb Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -181,7 +181,7 @@ src_compile() {
use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/$(get_libdir)/mysql" || myconf="${myconf} -no-sql-mysql"
use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql/pgsql" || myconf="${myconf} -no-sql-psql"
- use firebird && myconf="${myconf} -plugin-sql-ibase" || myconf="${myconf} -no-sql-ibase"
+ use firebird && myconf="${myconf} -plugin-sql-ibase -I/opt/firebird/include" || myconf="${myconf} -no-sql-ibase"
use sqlite3 && myconf="${myconf} -plugin-sql-sqlite -system-sqlite" || myconf="${myconf} -no-sql-sqlite"
use sqlite && myconf="${myconf} -plugin-sql-sqlite2" || myconf="${myconf} -no-sql-sqlite2"
use odbc && myconf="${myconf} -plugin-sql-odbc" || myconf="${myconf} -no-sql-odbc"