summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-02-11 12:08:24 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-02-11 12:08:24 +0000
commitfaf5c4a50bbd56fdb1e933fff3e513ded00e9f22 (patch)
tree8c24ae7f46b46ae7c19d66230c84dbc058db75cb /x11-libs
parentFix tags (bug #485718). (diff)
downloadgentoo-2-faf5c4a50bbd56fdb1e933fff3e513ded00e9f22.tar.gz
gentoo-2-faf5c4a50bbd56fdb1e933fff3e513ded00e9f22.tar.bz2
gentoo-2-faf5c4a50bbd56fdb1e933fff3e513ded00e9f22.zip
fix xv build against pre 1.13 servers, bug #499442.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/glamor/ChangeLog6
-rw-r--r--x11-libs/glamor/files/glamor-0.6.0-xv-add-missing-include.patch30
-rw-r--r--x11-libs/glamor/glamor-0.6.0.ebuild6
3 files changed, 40 insertions, 2 deletions
diff --git a/x11-libs/glamor/ChangeLog b/x11-libs/glamor/ChangeLog
index 3f0e7559769c..9731c3d1eba2 100644
--- a/x11-libs/glamor/ChangeLog
+++ b/x11-libs/glamor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/glamor
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/ChangeLog,v 1.26 2014/01/26 17:12:32 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/ChangeLog,v 1.27 2014/02/11 12:08:24 chithanh Exp $
+
+ 11 Feb 2014; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/glamor-0.6.0-xv-add-missing-include.patch, glamor-0.6.0.ebuild:
+ fix xv build against pre 1.13 servers, bug #499442.
*glamor-0.6.0 (26 Jan 2014)
diff --git a/x11-libs/glamor/files/glamor-0.6.0-xv-add-missing-include.patch b/x11-libs/glamor/files/glamor-0.6.0-xv-add-missing-include.patch
new file mode 100644
index 000000000000..ebd5433bdbe9
--- /dev/null
+++ b/x11-libs/glamor/files/glamor-0.6.0-xv-add-missing-include.patch
@@ -0,0 +1,30 @@
+From 55257ac3ee92143d0d8339faa0272f95a792febb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ch=C3=AD-Thanh=20Christopher=20Nguy=E1=BB=85n?=
+ <chithanh@gentoo.org>
+Date: Tue, 11 Feb 2014 12:08:07 +0100
+Subject: [PATCH] glamor_xv: add missing include
+
+glamor_xv.c uses DamageDamageRegion but does not include xorg/damage.h. This
+causes the build to fail if 9b8217f9ef6279fff6628631d18497bed0343ef9 is not
+present in the X server.
+
+Bugzilla: https://bugs.gentoo.org/show_bug.cgi?id=499442
+---
+ src/glamor_xv.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/glamor_xv.c b/src/glamor_xv.c
+index a89b4cd..b40b6e8 100644
+--- a/src/glamor_xv.c
++++ b/src/glamor_xv.c
+@@ -37,6 +37,7 @@
+ #ifdef GLAMOR_XV
+ #include "xf86xv.h"
+ #include <X11/extensions/Xv.h>
++#include <xorg/damage.h>
+ #include "fourcc.h"
+ /* Reference color space transform data */
+ typedef struct tagREF_TRANSFORM
+--
+1.8.3.2
+
diff --git a/x11-libs/glamor/glamor-0.6.0.ebuild b/x11-libs/glamor/glamor-0.6.0.ebuild
index 388dcbea3c8a..2f1e0550b19b 100644
--- a/x11-libs/glamor/glamor-0.6.0.ebuild
+++ b/x11-libs/glamor/glamor-0.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/glamor-0.6.0.ebuild,v 1.1 2014/01/26 17:12:32 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/glamor-0.6.0.ebuild,v 1.2 2014/02/11 12:08:24 chithanh Exp $
EAPI=5
@@ -26,6 +26,10 @@ RDEPEND=">=x11-base/xorg-server-1.10
>=x11-libs/pixman-0.21.8"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-xv-add-missing-include.patch
+)
+
src_configure() {
XORG_CONFIGURE_OPTIONS=(
$(use_enable gles glamor-gles2)