summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Keadle <mkeadle@gentoo.org>2002-12-12 22:21:14 +0000
committerMatt Keadle <mkeadle@gentoo.org>2002-12-12 22:21:14 +0000
commita487a2582169dbe77b50afd337205deafb1c5e2a (patch)
treeeca26e4711271a529057fb6fea1d45a2b8d549b7 /x11-misc/bbppp/bbppp-0.2.3.ebuild
parentAdded mips to keywords (diff)
downloadgentoo-2-a487a2582169dbe77b50afd337205deafb1c5e2a.tar.gz
gentoo-2-a487a2582169dbe77b50afd337205deafb1c5e2a.tar.bz2
gentoo-2-a487a2582169dbe77b50afd337205deafb1c5e2a.zip
Bump to latest version. Fixes issues with gcc3.x
Diffstat (limited to 'x11-misc/bbppp/bbppp-0.2.3.ebuild')
-rw-r--r--x11-misc/bbppp/bbppp-0.2.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-misc/bbppp/bbppp-0.2.3.ebuild b/x11-misc/bbppp/bbppp-0.2.3.ebuild
new file mode 100644
index 000000000000..e22e97ee400d
--- /dev/null
+++ b/x11-misc/bbppp/bbppp-0.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbppp/bbppp-0.2.3.ebuild,v 1.1 2002/12/12 22:21:14 mkeadle Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="blackbox ppp frontend/monitor"
+SRC_URI="http://bbtools.windsofstorm.net/sources/${P}.tar.gz"
+HOMEPAGE="http://bbtools.windsofstorm.net/available.phtml#bbppp"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc "
+
+DEPEND="virtual/blackbox"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc README COPYING AUTHORS BUGS INSTALL ChangeLog NEWS TODO data/README.bbppp
+}
+
+pkg_postinst() {
+ cd ${ROOT}usr/X11R6/bin/wm
+ if [ ! "`grep bbppp blackbox`" ] ; then
+ sed -e "s/.*blackbox/exec \/usr\/bin\/bbppp \&\n&/" blackbox | cat > blackbox
+ fi
+}