summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-20 17:13:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-20 17:13:17 +0000
commit36063e918a2d24ced245db291ffccc77c217d3a8 (patch)
tree1b16e2fee48bf7a37fb539c367ad281bf63e0245 /x11-misc/bubblemon
parentalpha/sparc stable wrt #304033 (diff)
downloadgentoo-2-36063e918a2d24ced245db291ffccc77c217d3a8.tar.gz
gentoo-2-36063e918a2d24ced245db291ffccc77c217d3a8.tar.bz2
gentoo-2-36063e918a2d24ced245db291ffccc77c217d3a8.zip
Fix showing up wrt #310399 by Roman Dobosz.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/bubblemon')
-rw-r--r--x11-misc/bubblemon/ChangeLog8
-rw-r--r--x11-misc/bubblemon/bubblemon-1.46-r2.ebuild44
-rw-r--r--x11-misc/bubblemon/files/bubblemon-1.46-no_display.patch24
3 files changed, 75 insertions, 1 deletions
diff --git a/x11-misc/bubblemon/ChangeLog b/x11-misc/bubblemon/ChangeLog
index 165a9431b6d5..4232103a1f99 100644
--- a/x11-misc/bubblemon/ChangeLog
+++ b/x11-misc/bubblemon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/bubblemon
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bubblemon/ChangeLog,v 1.37 2010/03/20 17:00:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bubblemon/ChangeLog,v 1.38 2010/03/20 17:13:16 ssuominen Exp $
+
+*bubblemon-1.46-r2 (20 Mar 2010)
+
+ 20 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +bubblemon-1.46-r2.ebuild, +files/bubblemon-1.46-no_display.patch:
+ Fix showing up wrt #310399 by Roman Dobosz.
20 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
bubblemon-1.46-r1.ebuild, +files/bubblemon-1.46-asneeded.patch:
diff --git a/x11-misc/bubblemon/bubblemon-1.46-r2.ebuild b/x11-misc/bubblemon/bubblemon-1.46-r2.ebuild
new file mode 100644
index 000000000000..b4dbf68ed94b
--- /dev/null
+++ b/x11-misc/bubblemon/bubblemon-1.46-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bubblemon/bubblemon-1.46-r2.ebuild,v 1.1 2010/03/20 17:13:16 ssuominen Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A fun monitoring applet for your desktop, complete with swimming duck"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${PN}-dockapp-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}-dockapp-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gtk.patch \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-no_display.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake GENTOO_CFLAGS="${CFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ dobin bubblemon || die
+
+ dodoc ChangeLog README doc/Xdefaults.sample
+
+ insinto /usr/share/${PN}
+ doins misc/*.{xcf,wav} || die
+
+ exeinto /usr/share/${PN}
+ doexe misc/wakwak.sh || die
+}
diff --git a/x11-misc/bubblemon/files/bubblemon-1.46-no_display.patch b/x11-misc/bubblemon/files/bubblemon-1.46-no_display.patch
new file mode 100644
index 000000000000..d1f1f0168d2d
--- /dev/null
+++ b/x11-misc/bubblemon/files/bubblemon-1.46-no_display.patch
@@ -0,0 +1,24 @@
+http://bugs.gentoo.org/310399
+
+--- bubblemon.c
++++ bubblemon.c
+@@ -44,7 +44,7 @@
+ */
+ #define _GNU_SOURCE
+
+-#define VERSION "1.41"
++#define VERSION "1.46"
+
+ /* general includes */
+ #include <stdio.h>
+@@ -607,10 +607,7 @@
+
+ gdk_window_show(bm.win);
+ XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
+-#ifdef KDE_DOCKAPP
+- /* makes the dockapp visible inside KDE wm */
+ gdk_window_show(bm.iconwin);
+-#endif
+
+ /* We begin with zero bubbles */
+ bm.n_bubbles = 0;