summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-02-11 21:57:38 +0000
committerSamuli Suominen <drac@gentoo.org>2008-02-11 21:57:38 +0000
commitd1cc6bdbaf1cf90f77efa99a2c89b1407ab06e3c (patch)
tree61f402bf6815524dc201dfa7de7f9ffa554142a6 /x11-misc/evolvotron/evolvotron-0.5.1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-d1cc6bdbaf1cf90f77efa99a2c89b1407ab06e3c.tar.gz
gentoo-2-d1cc6bdbaf1cf90f77efa99a2c89b1407ab06e3c.tar.bz2
gentoo-2-d1cc6bdbaf1cf90f77efa99a2c89b1407ab06e3c.zip
version bump
(Portage version: 2.1.4.3)
Diffstat (limited to 'x11-misc/evolvotron/evolvotron-0.5.1.ebuild')
-rw-r--r--x11-misc/evolvotron/evolvotron-0.5.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/evolvotron/evolvotron-0.5.1.ebuild b/x11-misc/evolvotron/evolvotron-0.5.1.ebuild
new file mode 100644
index 000000000000..1a66f6d34e31
--- /dev/null
+++ b/x11-misc/evolvotron/evolvotron-0.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/evolvotron/evolvotron-0.5.1.ebuild,v 1.1 2008/02/11 21:57:38 drac Exp $
+
+inherit qt3
+
+DESCRIPTION="An interactive generative art application"
+HOMEPAGE="http://www.bottlenose.demon.co.uk/share/evolvotron/index.htm"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="$(qt_min_version 3)"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+
+S="${WORKDIR}"/${PN}
+
+src_compile() {
+ export PATH="${QTDIR}/bin:${PATH}"
+ econf || die "econf failed."
+ emake -j1 || die "emake failed."
+}
+
+src_install() {
+ for bin in ${PN}{,_match,_mutate,_render}; do
+ dobin ${bin}/${bin}
+ done
+
+ doman man/man1/*
+
+ dodoc BUGS CHANGES README TODO USAGE
+}