summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-12-05 19:54:47 +0000
committerJim Ramsay <lack@gentoo.org>2007-12-05 19:54:47 +0000
commit8df1ab1c03bfde68c4adc8926c014a19f29e1fa2 (patch)
tree67b170ff53530b92b8d65d42171bbfe7cf0bbbbd /x11-misc/fbdesk
parentChange comment in site-init file. (diff)
downloadgentoo-2-8df1ab1c03bfde68c4adc8926c014a19f29e1fa2.tar.gz
gentoo-2-8df1ab1c03bfde68c4adc8926c014a19f29e1fa2.tar.bz2
gentoo-2-8df1ab1c03bfde68c4adc8926c014a19f29e1fa2.zip
Adding imlib2 USE flag for fbdesk-1.4.1 (bug 196166), and removed COPYING from dodoc in all versions
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-misc/fbdesk')
-rw-r--r--x11-misc/fbdesk/ChangeLog7
-rw-r--r--x11-misc/fbdesk/fbdesk-1.2.1.ebuild4
-rw-r--r--x11-misc/fbdesk/fbdesk-1.4.1.ebuild8
3 files changed, 13 insertions, 6 deletions
diff --git a/x11-misc/fbdesk/ChangeLog b/x11-misc/fbdesk/ChangeLog
index 3d21491b9288..99c2519e5e82 100644
--- a/x11-misc/fbdesk/ChangeLog
+++ b/x11-misc/fbdesk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/fbdesk
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/ChangeLog,v 1.23 2007/10/11 19:18:58 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/ChangeLog,v 1.24 2007/12/05 19:54:47 lack Exp $
+
+ 05 Dec 2007; Jim Ramsay <lack@gentoo.org> fbdesk-1.2.1.ebuild,
+ fbdesk-1.4.1.ebuild:
+ Adding imlib2 USE flag for fbdesk-1.4.1 (bug 196166), and removed COPYING
+ from dodoc in all versions
*fbdesk-1.4.1 (11 Oct 2007)
diff --git a/x11-misc/fbdesk/fbdesk-1.2.1.ebuild b/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
index be74b8e97245..27e84cd70def 100644
--- a/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
+++ b/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.2.1.ebuild,v 1.11 2007/10/11 19:18:58 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.2.1.ebuild,v 1.12 2007/12/05 19:54:47 lack Exp $
inherit eutils
@@ -37,5 +37,5 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS COPYING ChangeLog README
+ dodoc AUTHORS ChangeLog README
}
diff --git a/x11-misc/fbdesk/fbdesk-1.4.1.ebuild b/x11-misc/fbdesk/fbdesk-1.4.1.ebuild
index d511538379d0..9879dfcff3db 100644
--- a/x11-misc/fbdesk/fbdesk-1.4.1.ebuild
+++ b/x11-misc/fbdesk/fbdesk-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.4.1.ebuild,v 1.1 2007/10/11 19:18:58 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.4.1.ebuild,v 1.2 2007/12/05 19:54:47 lack Exp $
inherit eutils
@@ -11,9 +11,10 @@ SRC_URI="http://www.fluxbox.org/download/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~ia64 ~amd64"
-IUSE="debug png"
+IUSE="debug png imlib2"
RDEPEND="png? ( media-libs/libpng )
+ imlib2? ( media-libs/imlib2 )
x11-libs/libXpm
x11-libs/libXft"
DEPEND="${RDEPEND}
@@ -21,6 +22,7 @@ DEPEND="${RDEPEND}
src_compile() {
econf \
+ $(use_enable imlib2) \
$(use_enable debug) \
$(use_enable png) || die "econf failed"
@@ -29,5 +31,5 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS COPYING ChangeLog README
+ dodoc AUTHORS ChangeLog README
}