summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2013-01-27 18:31:04 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2013-01-27 18:31:04 +0000
commit0accae9019b530538cb7ba68cfbe5d49ebccfb72 (patch)
treeabc27af5b675e574fbfe84768f0c61f9e4f0a0a6 /x11-misc/i3status
parentsci-biology/samtools: Add missing deps and correct sed lines, #454134; thanks... (diff)
downloadgentoo-2-0accae9019b530538cb7ba68cfbe5d49ebccfb72.tar.gz
gentoo-2-0accae9019b530538cb7ba68cfbe5d49ebccfb72.tar.bz2
gentoo-2-0accae9019b530538cb7ba68cfbe5d49ebccfb72.zip
Drop old. Use new fcaps.eclass
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 895192F9)
Diffstat (limited to 'x11-misc/i3status')
-rw-r--r--x11-misc/i3status/ChangeLog8
-rw-r--r--x11-misc/i3status/i3status-2.5.1.ebuild80
-rw-r--r--x11-misc/i3status/i3status-2.6.ebuild55
-rw-r--r--x11-misc/i3status/metadata.xml3
4 files changed, 15 insertions, 131 deletions
diff --git a/x11-misc/i3status/ChangeLog b/x11-misc/i3status/ChangeLog
index 56fb36270a1c..9a5ad0f197c1 100644
--- a/x11-misc/i3status/ChangeLog
+++ b/x11-misc/i3status/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/i3status
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/i3status/ChangeLog,v 1.14 2012/12/16 16:33:16 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/i3status/ChangeLog,v 1.15 2013/01/27 18:31:04 xarthisius Exp $
+
+ 27 Jan 2013; Kacper Kowalik <xarthisius@gentoo.org> -i3status-2.5.1.ebuild,
+ i3status-2.6.ebuild, metadata.xml:
+ Drop old. Use new fcaps.eclass
16 Dec 2012; Agostino Sarubbo <ago@gentoo.org> i3status-2.6.ebuild:
Stable for x86, wrt bug #446950
diff --git a/x11-misc/i3status/i3status-2.5.1.ebuild b/x11-misc/i3status/i3status-2.5.1.ebuild
deleted file mode 100644
index db4fc630a0ab..000000000000
--- a/x11-misc/i3status/i3status-2.5.1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/i3status/i3status-2.5.1.ebuild,v 1.3 2012/06/26 07:25:44 jdhore Exp $
-
-EAPI=4
-
-inherit toolchain-funcs versionator
-
-DESCRIPTION="generates a status bar for dzen2, xmobar or similar"
-HOMEPAGE="http://i3wm.org/i3status/"
-SRC_URI="http://i3wm.org/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+caps"
-
-RDEPEND="dev-libs/confuse
- >=dev-libs/yajl-2.0.2
- media-libs/alsa-lib
- net-wireless/wireless-tools"
-DEPEND="${RDEPEND}
- caps? ( sys-libs/libcap )"
-
-# borrowed from GSoC2010_Gentoo_Capabilities by constanze and flameyeys
-# @FUNCTION: fcaps
-# @USAGE: fcaps {uid:gid} {file-mode} {cap1[,cap2,...]} {file}
-# @RETURN: 0 if all okay; non-zero if failure and fallback
-# @DESCRIPTION:
-# fcaps sets the specified capabilities in the effective and permitted set of
-# the given file. In case of failure fcaps sets the given file-mode.
-# Requires versionator.eclass
-fcaps() {
- local uid_gid=$1
- local perms=$2
- local capset=$3
- local path=$4
- local res
-
- chmod $perms $path && \
- chown $uid_gid $path
- res=$?
-
- use caps || return $res
-
- #set the capability
- setcap "$capset=ep" "$path" &> /dev/null
- #check if the capabilitiy got set correctly
- setcap -v "$capset=ep" "$path" &> /dev/null
- res=$?
-
- if [ $res -ne 0 ]; then
- ewarn "Failed to set capabilities. Probable reason is missing kernel support."
- ewarn "Your kernel must have <FS>_FS_SECURITY enabled (e.g. EXT4_FS_SECURITY)"
- ewarn "where <FS> is the filesystem to store ${path}"
- if ! version_is_at_least 2.6.33 "$(uname -r)"; then
- ewarn "For kernel 2.6.32 or older, you will also need to enable"
- ewarn "SECURITY_FILE_CAPABILITIES."
- fi
- ewarn
- ewarn "Falling back to suid now..."
- chmod u+s ${path}
- fi
- return $res
-}
-
-pkg_setup() {
- tc-export CC
-}
-
-src_prepare() {
- sed -e "/@echo/d" -e "s:@\$(:\$(:g" -e "/setcap/d" \
- -e '/CFLAGS+=-g/d' -i Makefile || die
-}
-
-pkg_postinst() {
- fcaps 0:users 550 cap_net_admin "${ROOT}"/usr/bin/${PN}
- elog "You need to install x11-misc/xmobar or x11-misc/dzen to use ${PN}."
- elog "Please refer to manual: man ${PN}"
-}
diff --git a/x11-misc/i3status/i3status-2.6.ebuild b/x11-misc/i3status/i3status-2.6.ebuild
index 2b8b55e329a6..425e920daa27 100644
--- a/x11-misc/i3status/i3status-2.6.ebuild
+++ b/x11-misc/i3status/i3status-2.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/i3status/i3status-2.6.ebuild,v 1.3 2012/12/16 16:33:16 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/i3status/i3status-2.6.ebuild,v 1.4 2013/01/27 18:31:04 xarthisius Exp $
EAPI=4
-inherit toolchain-funcs versionator
+inherit toolchain-funcs versionator fcaps
DESCRIPTION="generates a status bar for dzen2, xmobar or similar"
HOMEPAGE="http://i3wm.org/i3status/"
@@ -13,56 +13,13 @@ SRC_URI="http://i3wm.org/${PN}/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="+caps"
+IUSE=""
RDEPEND="dev-libs/confuse
>=dev-libs/yajl-2.0.2
media-libs/alsa-lib
net-wireless/wireless-tools"
-DEPEND="${RDEPEND}
- caps? ( sys-libs/libcap )"
-
-# borrowed from GSoC2010_Gentoo_Capabilities by constanze and flameyeys
-# @FUNCTION: fcaps
-# @USAGE: fcaps {uid:gid} {file-mode} {cap1[,cap2,...]} {file}
-# @RETURN: 0 if all okay; non-zero if failure and fallback
-# @DESCRIPTION:
-# fcaps sets the specified capabilities in the effective and permitted set of
-# the given file. In case of failure fcaps sets the given file-mode.
-# Requires versionator.eclass
-fcaps() {
- local uid_gid=$1
- local perms=$2
- local capset=$3
- local path=$4
- local res
-
- chmod $perms $path && \
- chown $uid_gid $path
- res=$?
-
- use caps || return $res
-
- #set the capability
- setcap "$capset=ep" "$path" &> /dev/null
- #check if the capabilitiy got set correctly
- setcap -v "$capset=ep" "$path" &> /dev/null
- res=$?
-
- if [ $res -ne 0 ]; then
- ewarn "Failed to set capabilities. Probable reason is missing kernel support."
- ewarn "Your kernel must have <FS>_FS_SECURITY enabled (e.g. EXT4_FS_SECURITY)"
- ewarn "where <FS> is the filesystem to store ${path}"
- if ! version_is_at_least 2.6.33 "$(uname -r)"; then
- ewarn "For kernel 2.6.32 or older, you will also need to enable"
- ewarn "SECURITY_FILE_CAPABILITIES."
- fi
- ewarn
- ewarn "Falling back to suid now..."
- chmod u+s ${path}
- fi
- return $res
-}
+DEPEND="${RDEPEND}"
pkg_setup() {
tc-export CC
@@ -74,7 +31,7 @@ src_prepare() {
}
pkg_postinst() {
- fcaps 0:users 550 cap_net_admin "${ROOT}"/usr/bin/${PN}
+ fcaps cap_net_admin usr/bin/${PN}
elog "You need to install x11-misc/xmobar or x11-misc/dzen to use ${PN}."
elog "Please refer to manual: man ${PN}"
}
diff --git a/x11-misc/i3status/metadata.xml b/x11-misc/i3status/metadata.xml
index f2ab65f7a817..29dbb30b93cd 100644
--- a/x11-misc/i3status/metadata.xml
+++ b/x11-misc/i3status/metadata.xml
@@ -14,4 +14,7 @@
status bar is updated correctly. Also, it saves a bit of energy by not hogging
your CPU as much as spawning the corresponding amount of shell commands would.
</longdescription>
+ <use>
+ <flag name="filecaps">Linux capabilities library is required for i3status to be able to read net bandwith</flag>
+ </use>
</pkgmetadata>