summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-05-07 01:00:14 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-05-07 01:00:14 +0000
commitd83da0ee3703f2f2ab506b025d67db312707f956 (patch)
treea0d7a0ba0caeca19d758d3c4451565e0e3ab5e91 /x11-misc/jaffm/jaffm-1.2.1.ebuild
parentRemove old version (diff)
downloadgentoo-2-d83da0ee3703f2f2ab506b025d67db312707f956.tar.gz
gentoo-2-d83da0ee3703f2f2ab506b025d67db312707f956.tar.bz2
gentoo-2-d83da0ee3703f2f2ab506b025d67db312707f956.zip
Fix GCC 4 compile error (bug #150823), wxGTK usage, and general Makefile
cruddiness. (Portage version: 2.1.2.6)
Diffstat (limited to 'x11-misc/jaffm/jaffm-1.2.1.ebuild')
-rw-r--r--x11-misc/jaffm/jaffm-1.2.1.ebuild27
1 files changed, 17 insertions, 10 deletions
diff --git a/x11-misc/jaffm/jaffm-1.2.1.ebuild b/x11-misc/jaffm/jaffm-1.2.1.ebuild
index d5b33a59c359..b045b546c4d9 100644
--- a/x11-misc/jaffm/jaffm-1.2.1.ebuild
+++ b/x11-misc/jaffm/jaffm-1.2.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/jaffm/jaffm-1.2.1.ebuild,v 1.6 2006/04/10 19:52:01 smithj Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/jaffm/jaffm-1.2.1.ebuild,v 1.7 2007/05/07 01:00:14 dirtyepic Exp $
-inherit eutils
+inherit eutils toolchain-funcs wxwidgets
DESCRIPTION="Very lightweight file manager"
HOMEPAGE="http://jaffm.binary.is/"
@@ -15,15 +15,22 @@ SLOT="0"
KEYWORDS="~ppc x86"
IUSE=""
-DEPEND=">=x11-libs/wxGTK-2.6"
+DEPEND="=x11-libs/wxGTK-2.6*"
src_unpack() {
- unpack "${A}"
- epatch "${FILESDIR}/${P}-wx24.patch"
-}
-
-src_compile() {
- emake || die
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-wx24.patch
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+
+ WX_GTK_VER="2.6"
+ need-wxwidgets gtk2
+ sed -i \
+ -e "/^CPP=/ s:g++:$(tc-getCXX):" \
+ -e "/^PREFIX=/ s:/local::" \
+ -e "s:wx-config:${WX_CONFIG}:g" \
+ -e "/^FLAGS=/ s:^.*$:FLAGS=${CXXFLAGS}:" \
+ Makefile
}
src_install() {