summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-09-07 19:40:08 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-09-07 19:40:08 +0000
commitf62de8c4ed04b8de5322c4ea54d4571b8da1c717 (patch)
treefe59093b4f9ec74754ac06c8fff1fc7f9c383038 /x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-1.9.0.ebuild
parentVersion bump (diff)
downloadgentoo-2-f62de8c4ed04b8de5322c4ea54d4571b8da1c717.tar.gz
gentoo-2-f62de8c4ed04b8de5322c4ea54d4571b8da1c717.tar.bz2
gentoo-2-f62de8c4ed04b8de5322c4ea54d4571b8da1c717.zip
Version bump
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-1.9.0.ebuild')
-rw-r--r--x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-1.9.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-1.9.0.ebuild b/x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-1.9.0.ebuild
new file mode 100644
index 000000000000..5a4ea45417c0
--- /dev/null
+++ b/x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-1.9.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-1.9.0.ebuild,v 1.1 2014/09/07 19:40:08 hwoarang Exp $
+
+EAPI=4
+
+inherit versionator
+
+DESCRIPTION="LightDM GTK+ Greeter"
+HOMEPAGE="http://launchpad.net/lightdm-gtk-greeter"
+SRC_URI="http://launchpad.net/lightdm-gtk-greeter/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz branding? (
+http://dev.gentoo.org/~hwoarang/distfiles/lightdm-gentoo-patch-2.tar.gz )"
+
+LICENSE="GPL-3 LGPL-3
+ branding? ( CC-BY-3.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="branding"
+
+DEPEND="x11-libs/gtk+:3
+ >=x11-misc/lightdm-1.2.2"
+RDEPEND="!!<x11-misc/lightdm-1.1.1
+ x11-libs/gtk+:3
+ >=x11-misc/lightdm-1.2.2
+ x11-themes/gnome-themes-standard
+ x11-themes/gnome-icon-theme"
+
+GENTOO_BG="gentoo-bg_65.jpg"
+
+src_prepare() {
+ # Ok, this has to be fixed in the tarball but I am too lazy to do it.
+ # I will fix this once I decide to update the tarball with a new gentoo
+ # background
+ # Bug #404467
+ if use branding; then
+ sed -i -e "/xft-hintstyle/s:slight:hintslight:" \
+ "${WORKDIR}"/${PN}.conf || die
+ fi
+}
+
+src_install() {
+ default
+
+ if use branding; then
+ insinto /etc/lightdm/
+ doins "${WORKDIR}"/${PN}.conf
+ insinto /usr/share/lightdm/backgrounds/
+ doins "${WORKDIR}"/${GENTOO_BG}
+ sed -i -e \
+ "/background/s:=.*:=/usr/share/lightdm/backgrounds/${GENTOO_BG}:" \
+ "${D}"/etc/lightdm/${PN}.conf || die
+ newdoc "${WORKDIR}"/README.txt README-background.txt
+ fi
+}