summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-06-03 19:41:48 +0000
committerSamuli Suominen <drac@gentoo.org>2007-06-03 19:41:48 +0000
commit85c91112d25baaaccec61aee2f07710a29039dc7 (patch)
treeb068a6e5513761309ab0da794d6a12d40127a2d0 /x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0.ebuild
parentStable on amd64, ppc, ppc64, sparc, x86 as per #175560 (diff)
downloadgentoo-2-85c91112d25baaaccec61aee2f07710a29039dc7.tar.gz
gentoo-2-85c91112d25baaaccec61aee2f07710a29039dc7.tar.bz2
gentoo-2-85c91112d25baaaccec61aee2f07710a29039dc7.zip
Version bump.
(Portage version: 2.1.2.9)
Diffstat (limited to 'x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0.ebuild')
-rw-r--r--x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0.ebuild b/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0.ebuild
new file mode 100644
index 000000000000..acaa3a7a6edc
--- /dev/null
+++ b/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineak-defaultplugin/lineak-defaultplugin-0.9.0.ebuild,v 1.1 2007/06/03 19:41:48 drac Exp $
+
+inherit multilib
+
+MY_P=${P/.0/}
+
+DESCRIPTION="Mute/unmute and other macros for LINEAK"
+HOMEPAGE="http://lineak.sourceforge.net"
+SRC_URI="mirror://sourceforge/lineak/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+RDEPEND="=x11-misc/lineakd-${PV}*"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_compile() {
+ econf $(use_enable debug)
+ emake || die "emake failed."
+}
+
+src_install() {
+ sed -i -e 's:$(DESTDIR)${DESTDIR}:$(DESTDIR):' default_plugin/Makefile
+
+ emake DESTDIR="${D}" \
+ PLUGINDIR=/usr/$(get_libdir)/lineakd/plugins \
+ install || die "emake install failed."
+ dodoc AUTHORS README
+}