summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-13 11:48:48 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-13 11:48:48 +0000
commit5305fa6efabe5af09f4e27cfdf7b1a75afc8125e (patch)
tree425dd78799ae53199b5034a35b6458a781c8f25c /x11-misc/notify-osd
parentVersion bump. (diff)
downloadgentoo-2-5305fa6efabe5af09f4e27cfdf7b1a75afc8125e.tar.gz
gentoo-2-5305fa6efabe5af09f4e27cfdf7b1a75afc8125e.tar.bz2
gentoo-2-5305fa6efabe5af09f4e27cfdf7b1a75afc8125e.zip
Initial commit wrt #280775 by Mikel Olasagasti.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/notify-osd')
-rw-r--r--x11-misc/notify-osd/ChangeLog10
-rw-r--r--x11-misc/notify-osd/metadata.xml9
-rw-r--r--x11-misc/notify-osd/notify-osd-0.9.30.ebuild45
3 files changed, 64 insertions, 0 deletions
diff --git a/x11-misc/notify-osd/ChangeLog b/x11-misc/notify-osd/ChangeLog
new file mode 100644
index 000000000000..7ab5a18858cb
--- /dev/null
+++ b/x11-misc/notify-osd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/notify-osd
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notify-osd/ChangeLog,v 1.1 2011/03/13 11:48:48 ssuominen Exp $
+
+*notify-osd-0.9.30 (13 Mar 2011)
+
+ 13 Mar 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +notify-osd-0.9.30.ebuild:
+ Initial commit wrt #280775 by Mikel Olasagasti.
+
diff --git a/x11-misc/notify-osd/metadata.xml b/x11-misc/notify-osd/metadata.xml
new file mode 100644
index 000000000000..f1d365960b36
--- /dev/null
+++ b/x11-misc/notify-osd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-misc/notify-osd/notify-osd-0.9.30.ebuild b/x11-misc/notify-osd/notify-osd-0.9.30.ebuild
new file mode 100644
index 000000000000..14866016792a
--- /dev/null
+++ b/x11-misc/notify-osd/notify-osd-0.9.30.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notify-osd/notify-osd-0.9.30.ebuild,v 1.1 2011/03/13 11:48:48 ssuominen Exp $
+
+EAPI=2
+inherit autotools gnome2-utils
+
+DESCRIPTION="Canonical's on-screen-display notification agent"
+HOMEPAGE="http://launchpad.net/notify-osd"
+SRC_URI="http://launchpad.net/${PN}/natty/natty-alpha3/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/dbus-glib-0.88
+ >=dev-libs/glib-2.16:2
+ gnome-base/gconf:2
+ >=x11-libs/gtk+-2.22
+ >=x11-libs/libnotify-0.4.5
+ x11-libs/libwnck
+ x11-libs/libX11
+ x11-libs/pixman
+ !xfce-extra/xfce4-notifyd
+ !x11-misc/notification-daemon"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xproto"
+
+RESTRICT="test" # Test suite is broken with libnotify-0.7 API
+
+src_prepare() {
+ sed -i -e '/SUBDIRS/s:tests ::' Makefile.am || die # ditto
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }