summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-02-11 11:22:28 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-02-11 11:22:28 +0000
commit358fb399db9e37d93854dcb8e42204db9e5bd41c (patch)
treea5936b23199610c7bbf09305b4715819c3d9fa1d /x11-misc/peksystray/peksystray-0.2.1.ebuild
parentFixed DEPEND for modular X. (diff)
downloadgentoo-2-358fb399db9e37d93854dcb8e42204db9e5bd41c.tar.gz
gentoo-2-358fb399db9e37d93854dcb8e42204db9e5bd41c.tar.bz2
gentoo-2-358fb399db9e37d93854dcb8e42204db9e5bd41c.zip
Fixed DEPEND for modular X.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'x11-misc/peksystray/peksystray-0.2.1.ebuild')
-rw-r--r--x11-misc/peksystray/peksystray-0.2.1.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/x11-misc/peksystray/peksystray-0.2.1.ebuild b/x11-misc/peksystray/peksystray-0.2.1.ebuild
index 33b8d1a3addb..49cdba010c36 100644
--- a/x11-misc/peksystray/peksystray-0.2.1.ebuild
+++ b/x11-misc/peksystray/peksystray-0.2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/peksystray/peksystray-0.2.1.ebuild,v 1.6 2005/08/07 13:39:51 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/peksystray/peksystray-0.2.1.ebuild,v 1.7 2006/02/11 11:22:28 nelchael Exp $
inherit eutils
@@ -11,16 +11,20 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha ppc x86"
-DEPEND="virtual/x11"
IUSE=""
+RDEPEND="|| ( (
+ x11-libs/libXt
+ x11-libs/libX11 )
+ virtual/x11 )"
+DEPEND="${RDEPEND}"
+
src_compile() {
- econf --x-libraries=/usr/X11R6/lib || die
+ econf --x-libraries=/usr/lib || die
emake || die
}
src_install() {
dobin src/peksystray
-
dodoc AUTHORS NEWS README THANKS TODO
}