summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-08-27 16:24:10 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-08-27 16:24:10 +0000
commitcb40e0bcab1e2a7cfe79880b978e58d5cb0f6aef (patch)
tree207ff6103b70e886034364a903d5ce20cd365bf8 /x11-misc/pogo/pogo-2.2-r1.ebuild
parentRespect LDFLAGS wrt bug 333979. Thanks to Diego for the report. (diff)
downloadgentoo-2-cb40e0bcab1e2a7cfe79880b978e58d5cb0f6aef.tar.gz
gentoo-2-cb40e0bcab1e2a7cfe79880b978e58d5cb0f6aef.tar.bz2
gentoo-2-cb40e0bcab1e2a7cfe79880b978e58d5cb0f6aef.zip
Respect CC and LDFLAGS wrt bug 334565. Thanks to Diego for the report.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/pogo/pogo-2.2-r1.ebuild')
-rw-r--r--x11-misc/pogo/pogo-2.2-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/pogo/pogo-2.2-r1.ebuild b/x11-misc/pogo/pogo-2.2-r1.ebuild
new file mode 100644
index 000000000000..c172749756e3
--- /dev/null
+++ b/x11-misc/pogo/pogo-2.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pogo/pogo-2.2-r1.ebuild,v 1.1 2010/08/27 16:24:10 xarthisius Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Pogo is a neat launcher program for X"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+# upstream no longer exists
+HOMEPAGE="http://packages.gentoo.org/package/x11-misc/pogo"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ media-libs/imlib
+ media-libs/jpeg
+ >=sys-apps/sed-4"
+
+src_prepare() {
+ cp "${FILESDIR}"/Makefile-r1 Makefile || die
+ sed -i -e "s:/usr/local:/usr/share:g" configs/* pogo.c || die
+}
+
+src_compile() {
+ emake clean || die
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README || die
+}