summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-05-04 06:33:06 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-05-04 06:33:06 +0000
commitbc85955963daa9249134cd2b12ebc9300ba78365 (patch)
tree02473f35e37b2be855723b9120014d73f9afd7c9 /x11-misc/redshift/redshift-1.6-r1.ebuild
parentppc stable wrt #365177 (diff)
downloadgentoo-2-bc85955963daa9249134cd2b12ebc9300ba78365.tar.gz
gentoo-2-bc85955963daa9249134cd2b12ebc9300ba78365.tar.bz2
gentoo-2-bc85955963daa9249134cd2b12ebc9300ba78365.zip
Apply patch for >gnome-2.30 wrt bug 365481 by Anton Bolshakov <anton.bugs@gmail.com>. Drop old.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/redshift/redshift-1.6-r1.ebuild')
-rw-r--r--x11-misc/redshift/redshift-1.6-r1.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/x11-misc/redshift/redshift-1.6-r1.ebuild b/x11-misc/redshift/redshift-1.6-r1.ebuild
new file mode 100644
index 000000000000..725f2fe650a4
--- /dev/null
+++ b/x11-misc/redshift/redshift-1.6-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/redshift/redshift-1.6-r1.ebuild,v 1.1 2011/05/04 06:33:06 xarthisius Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="gtk? 2:2.6"
+
+inherit eutils gnome2-utils python
+
+DESCRIPTION="A screen color temperature adjusting software"
+HOMEPAGE="http://jonls.dk/redshift/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome gtk nls"
+
+COMMON_DEPEND=">=x11-libs/libX11-1.4
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ gnome? ( dev-libs/glib:2
+ >=gnome-base/gconf-2 )"
+RDEPEND="${COMMON_DEPEND}
+ gtk? ( >=dev-python/pygtk-2
+ dev-python/pyxdg )"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ use gtk && python_set_active_version 2
+}
+
+src_prepare() {
+ if use gtk; then
+ rm -f py-compile
+ ln -s $(type -P true) py-compile || die
+ python_convert_shebangs 2 src/gtk-redshift/gtk-redshift
+ fi
+ epatch "${FILESDIR}"/${PV}-bonoboiidfix.patch
+}
+
+src_configure() {
+ local myconf
+ use gtk || myconf="--disable-gui"
+
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ --enable-randr \
+ --enable-vidmode \
+ $(use_enable gnome gnome-clock) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ use gtk && python_mod_optimize gtk_${PN}
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ use gtk && python_mod_cleanup gtk_${PN}
+}