summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2004-09-02 18:31:28 +0000
committerBryan Stine <battousai@gentoo.org>2004-09-02 18:31:28 +0000
commit8dccddc9f258276e4d45a66bf290f8e7e7a7a359 (patch)
tree3bc44aa44495eb6d2b1f7021909ea9de209a1292 /x11-misc/synaptics/synaptics-0.13.5.ebuild
parentKeyword modification, see changelog for details (Manifest recommit) (diff)
downloadgentoo-2-8dccddc9f258276e4d45a66bf290f8e7e7a7a359.tar.gz
gentoo-2-8dccddc9f258276e4d45a66bf290f8e7e7a7a359.tar.bz2
gentoo-2-8dccddc9f258276e4d45a66bf290f8e7e7a7a359.zip
Bump to 0.13.5, closes 62501.
Diffstat (limited to 'x11-misc/synaptics/synaptics-0.13.5.ebuild')
-rw-r--r--x11-misc/synaptics/synaptics-0.13.5.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/synaptics/synaptics-0.13.5.ebuild b/x11-misc/synaptics/synaptics-0.13.5.ebuild
new file mode 100644
index 000000000000..849ec6fce4e0
--- /dev/null
+++ b/x11-misc/synaptics/synaptics-0.13.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/synaptics-0.13.5.ebuild,v 1.1 2004/09/02 18:31:28 battousai Exp $
+
+inherit eutils
+
+# This ebuild overwrites synaptics files installed by <= xfree-4.3.0-r6
+# and xfree-4.3.99.14 >= X >= xfree-4.3.99.8.
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://w1.894.telia.com/~u89404340/touchpad/"
+SRC_URI="http://w1.894.telia.com/~u89404340/touchpad/files/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND="|| ( x11-base/xorg-x11 >=x11-base/xfree-4.3.0-r6 )"
+DEPEND=">=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Put stuff into /usr/X11R6, also switch up the CC and CFLAGS stuff.
+ sed -i -e "s:BINDIR = \\\$(DESTDIR)/usr/local/bin:BINDIR = ${D}/usr/X11R6/bin:g" ${S}/Makefile
+ sed -i -e "s:CC = gcc:CC = ${CC}:g" ${S}/Makefile
+ sed -i -e "s:CDEBUGFLAGS = -O2:CDEBUGFLAGS = ${CFLAGS}:g" ${S}/Makefile
+ sed -i -e "s:MANDIR = .*:MANDIR = \\\$(DESTDIR)/usr/man/man1:" ${S}/Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dodir /usr/X11R6/{bin,lib/modules/input}
+
+ # Yes, they got the DESTDIR stuff going. And there was much rejoicing.
+ make DESTDIR=${D} install || die
+ dodoc {script/usbmouse,alps.patch,COMPATIBILITY,FILES,INSTALL{,.DE},LICENSE,NEWS,TODO,README{,.alps}}
+ # Stupid new daemon, didn't work for me because of shm issues
+ exeinto /etc/init.d && newexe ${FILESDIR}/rc.init syndaemon
+ insinto /etc/conf.d && newins ${FILESDIR}/rc.conf syndaemon
+}